New 4.2.2 kernel panics on proxmox VM [Solved]

Root is a sata0 on a proxmox VM.

If I boot the old 4.1 kernel rockstor starts fine.

Did a yum reinstall kernel-ml which seems to have fixed it,

1 Like

That is a bit strange, but I am glad it worked at the end. Currently, Proxmox is not part of our environment here, so it’s not tested by us at the moment. However, I think there are few users in your situation out there and it would be great if one of you signs off on kernel updates.

Going forward, users can either activate Stable updates or Testing updates. So you can sign off upcoming kernel updates, if any, from the Testing updates.

Btw, the title of this post is very generic, so I’ll update it to be specific.

I realised I had the virtual HDDS on writethrough caching (opps) also the underlying Storage for the boot drive was under heavy load at the time as I’ve just taken a number of larger KVM instances and split them down into containers for individual roles only using full virt where it makes sense (E.g need a specific kernel/kernel-module)

It’s possible something simply timed out during kernel installation.

The good news is that I’m nearly at the point I want to be where I’ve gotten shot of a load of older larger VM instances. I’ve also managed to move the data from my owncloud VM onto rockstor (NFS mount). I’m almost at the point where there is no important data on my drives that hold the VM’s themselves once that’s done I’ll prob replace the aging raid 1 with a single SSD and just set a job to back it up weekly (After all if it’s just virtual machine OS files does it really need to be raid :wink: )