New install - "Job rockstor.service/start failed with result 'dependency'"

Hey there

I just wanted to try out Rockstor on my newly built NAS, but I can’t reach the web interface after starting.

I dug a little in the command line and noticed that the rockstor service is inactive :face_with_raised_eyebrow:

Although this system is new and I haven’t installed any OS jet, I run a few independent live-OSes that worked, memtest86+ among other things.
I tried the Leap 15.4 and the tumbleweed Version of Rockstor, both with the same symptoms.
When starting the system manually - although it will never return to the command line - only brings up nginx with 502 Bad Gateway in my browser.

Could someone help me out what might gone wrong?
How can I check the logs of this Job?
Do you have any other clues where I could find this failing dependency?

I do appreciate your help in advance.

@simon-77 Welcome the the Rockstor community forum.

The dependency is likely the first required service of rockstor-pre.

What does the following command give you:

systemctl status rockstor-pre

And can you give us some info abotu this NAS system. I’m wondering if the install drive is too small or something like that. See our:
Minimum system requirements

We have 3 main rockstor service in total rockstor-pre, rockstor, and finally rockstor-bootstrap. They start (or are supposed to start :slight_smile: ) in that order.

Hope that helps.


Hi, thank you for your quick reply :blush:

The rockstor-pre service unfortunatelly has the same error:

My system is self built, has an Asus P12R-I Server MB ; an Xenon 4-Core CPU (E-2314); 16 GB of ECC RAM, 2 ethernet ports (for the OS) and storage:

  • 2x 18 TB HDD (SATA)
  • 1x 1 TB HDD (M.2 PCIE)

But the Rockstor OS is installed on a 16 GB USB 3 Stick - originally intended for using unRAID.
Yesterday I stumbled across this great project and decided to give it a try :blush:

Any further advice, what are the dependencies for the rockstor-pre service? :thinking:

… well, looks like my USB device is faulty :unamused:

Alright, a simple explanation for follow up readers of this issue:

I installed Rockstor (including the openSUSE OS) onto an USB stick - /dev/sdc in my case.
Althought installing an OS onto an USB stick is not ideal for reliability - as seen in my case - it is not fundamentally wrong.

Plain openSUSE OS uses BTRFS as filesystem for the OS - completely independent from the btrfs filesystem used by Rockstor for the “HDD storage”.

Among other advantages, BTRFS uses a checksum for every file in order to detect hardware errors - when using other filesystem (e.g. ext4, NTFS, …) a hardware error might lead to a changed file undetected.

Every time a file gets read from a BTRFS filesystem the checksum is checked. In my case whatever process tried to access the damaged file could not start and through whatever chain of dependencies lead to the service rockstor not even trying to start.
BTRFS in this case has done it’s job of not letting start service with corrupted files - to whatever this would have lead …
In case a RAID1-BTRFS would have been used (like for the “HDD storage”), BTRFS would of course simply load the file from the other device and and present it to the process “normally” and “just” logg this issue to the system.

The dmesg log in my case looks like this: (sorry, I am only allowed to put one image into a post :roll_eyes:)

The “counter” of BTRFS errors can be checked on a mounted filesystem: (. is the mounted path, sudo privilege required)

# btrfs device stats .

Append the -z flag to reset the counter after printing the values.

I then started a scrub, where btrfs reads every single file from the device to validate the checksum:

# btrfs scrub start .
# watch btrfs srub status .

(the second command is for “watching” the progress of scrub)

After the scrub is finished I again checked (previousely reset) btrfs status:


My (new) USB stick is damaged and this caused the issue.

… although I bought it from a “well-known” brand (Intenso)
… although it is the “Premium” line of this brand
… and although it has a metal enclousure for “optimal heat dissapation”
(these are often-recommended things for buying a USB stick where the OS is installed onto)

Never mind, this USB stick will go back to Amazon, but it is still annoying for me having all these troubles.

I have to say, this is just one more example of almost a dozen failed USB-Sticks and micro SD-cards - I have experienced a terrible failure rate with these device (subjectively ~ 30%) - some of them immediately (like in this case), and some after some usage.

And in contrast - although heavily used - I haven’t had a single failure in any 2.5" or M.2 SSD.
These device seem to much more reliable.

Cheers, Simon

1 Like

Here is the example dmesg output for my corrupted BTRFS volume:

Follow up:

I have installed Rockstor to my M.2 SSD and everything works like a charm :smiling_face:


Glad, you figured that portion out. I have had very mixed experiences with that USB stick brand, both from a read/write performance as well as a reliability perspective (I think I even had one of the ones you used, and it literally fell apart after some time).


Well … I got a replacement USB stick and thought I’d try using it as OS drive again (Rockstor Leap 15.4) - out of curiosity.
Interestingly it does not work again, but I do get different errors this time :sweat_smile:

When I boot the system, I do get the following output:

  • /dec/sdc4 ist the OS partition labeld ROOT
    There are no BTRFS errors on this partition and I also run a scrub successfully
  • /dev/sdc2 - I also run fsck without errors

I don’t really understand what is going on here. The failed dependency suggests that the filesystem check for /dev/sdc4 failed … although this partition seems to be fine …
The system logs are also not conclusive for me what is going wrong.
I have saved the /run/initramfs/rdsosreport.txt: pastebin link

I have just installed Rockstore on my NVMe drive - everything works fine and I don’t need any assistance on resolving this issue regarding my USB drive.

This test was mainly out of curiosity, but I still do have the USB stick with this not-working Rockstor installation. If someone is curious too and has some hints for finding the issue or bug I do look forward for a reply and can spin up the USB stick again for running further test.


PS. I am on holidays starting tomorrow until end of August, so unfortunately I will not be able to respond during this time.


@simon-77. Enjoy your vacation. Just one quick question, did you create the bootable USB using Etcher?

1 Like

Thank you :blush:

No, I actually used the iKVM feature of my motherboard to mount the .iso image through KVM.
For installation on the NVMe SSD this worked well every time.

1 Like