Newbie needs help

Hi: as stated in the title I’m a newbie here. I am trying to install Rockstor Personal Cloud on an I3 Acer laptop using a USB Boot disk. Everything went fine until the install instructions said to logon to localhost - everytime I tried to access via a web browser from my Ipad or another Windows 10 laptop I get the same error message: Local Host refused connection - ERR_CONNECTION_REFUSED - I’ve researched until my fingers ached but still couldn’t find anything to help. Has anyone here seen this before? Any help is greatly appreciated.


Hi Lindsay
I am also in the Newbie sector, in fact I think I am in the pre newbie class after reading all these posts. (Have to have a glossery of terms open all the time).
I had a similar experience when opening the GUI first time, untill I used the Https://, access wasn’t granted.
Hope this helps —(Can’t believe i’m attempting to help another user)

1 Like

Yes you will need to access https://ip_address_of acer_laptop from a browser to get to the Rockstor webGUI from another device.

If unsure of the Acer laptop IP address, log in to the Rockstor install on the Acer laptop itself using the password you created during installation. Once in, enter the myip command to get the ip address, then use this address to access the GUI from your iPad or W10 devices. Once successful, feel free to log out of the Acer laptop as you will be doing everything via the WebGUI.

Hope this helps.


Thanks, Mike - I tried that before but will check o make sure I typed it correctly and try again.

Thanks, GeoffA _ i will try but last time I tried it the install defaulted back to LocaHost Login and I could get to a command prompt to do anything else

@ljeisan Welcome to the Rockstor community.

First off, what @Mike-B & @GeoffA said.

Plus, are you using our latest installer from the downloads page. It has the @GeoffA mentioned


program that should given you the actual ip.

Hope that helps. Also note that laptops can be a little more tricky as they often have elements of the system powered off untill specifically enabled. You could look into the bios/uefi setup screen and unsure the network port is powered on by default. Desktop systems will often do this auto style, but we are predominantly a server install and they tend to expect stuff to be powered on from the get-go.

For a more advanced look at exactly what’s going on with your network you can also use the command line network manager interface, i.e.:


You can always past the output of that command into this thread if it’s all nonsense. But all can be looked up on the internet also and it should show if your network card is even available.

Hope that helps.


Thanks all. I’ve tried the suggestions above except for re-installing. At this point I still can’t get past Localhost Login and I’ve tried using the actual IP as well as and trying to access using anothe device doesn’t work either. I have also made a true rookie mistake when installing I thought i was installing to a connected device (USB Drive) but apparently installed in on the internal drive and have wiped out my original Windows install. Not really concerned about that because I wasn’t using it anyways but now I can’t boot from an alternate device like the USB Flash port or CD/DVD drive to reinstall a new OS (was trying to install Ubuntu from an ISO) but I keep getting a System Locked error. How do I unistall Rockstor to install Ubuntu? Thanks

Can’t say I have seen that before, can you post the exact error you’re seeing?

In general, you might have to wipe the drive(s) thoroughly before you can install something else:

Thanks - except for the fact that Rockstor loads regardless of how set boot order it always defaults back to Rockstor and the grub prompt.

That almost makes it seem like a BIOS issue, since that “decision” happens before Rockstor or any other OS intervenes if I am not mistaken.


I don’t know exactly which mobo/chipset you have but when the laptop boots you may find that pressing F12 at the Acer splashscreen (its not up there for long so keep your eyes open and a finger poised over the button) will bring up a boot menu option. from which you should be able to see and select your USB install device. I have laptops and desktops that have this.

EDIT: on some laptops I believe the Boot Menu is disabled by default, and needs to be activated in the BIOS settings first. Either the Del key or F2 key pressed at the Acer splash screen mentioned above should get you into the BIOS settings. I say ‘should’ as not all devices use the same keys to access the Bios.

Thanks GeoffA - I have actually tried using the F12 boot Menu but it still boots to the HDD even if I’ve selected the ATAPI CD or External USB - I have tried with both Secure Boot off and on and switching between Legacy and UEFI. Alwys still boots to HDD and I get the GRUB> prompt after Rockstor fails to load.

Some laptops don’t have have a “boot menu” option enabled by default. I think you might have to use the “F2” key to access/modify your BIOS settings. There, you should be able to configure your BIOS settings regarding which boot devices you want to select as the first, second, third, etcetera boot options. You might also find an option to enable the “F12 boot menu” option, though it could be different. For example, I have a couple of computers that use a different function key (but they aren’t Acer machines). Also, I would consider disabling “Secure Boot” for installing linux on your laptop, as it makes some linux installations a bit easier. Anyhow, that should (hopefully) get you back on track to being able to re-attempt to boot from a USB or CDROM device to use as your installation media source.