Nginx-proxy-manager, no GUI - Rockstor version: 4.0.6-0

I’m running Owncloud-Official connected to Mariadb and it seems to work well. I would love to access my owncloud by SSL so I tried to install Nginx-proxy-manager since it seems to be a way to make this work. Unfortunately, I can’t access the Nginx-proxy-Manager UI. I have tried several ports and setups with no luck. Any suggestion on how to do it? Can I get Nginx-proxy-manager to work or do I need to use another way to achieve SSL for my Owncloud service?

My setup is:
Rockstor version: 4.0.6-0 (it didn’t work on 4.0.4-0 either)
Nginx-proxy-manager

Hi @Roysen,

I believe you are hitting a recent limitation detected with this rockon, related to IPv6. This was detected and reported by @Marenz, who also prepared a fix in the rockon-registry repository on Github:

We just have one detail to finalize with this and I should be able to merge and publish it after that.

1 Like

@Roysen, as a perfect illustration of how much one can rely on this community, @Marenz just pushed the final fix for this on Github (see issue linked above) so I will try to merge and publish that by the end of the day.

Thanks a lot for such a quick reaction @Marenz!

2 Likes

Thank you for the update @Flox and to @Marenz for the fix. A short question, do I need to reinstall my Nginx-proxy rock-ons to get the new update version when it is published?

Hi @Roysen,

Yesterday was unfortunately too busy for me to tend to this matter, but I could merge and publish @Marenz’s fix just now. See announcement below:

Yes. Briefly, the procedure should be as follows:

  • Uninstall the rock-on
  • Click on the “Update” button in the top right corner of the Rock-ons page to refresh the list of available rock-ons and refresh their definition. This will ensure you have the rock-on definition that include the fix.
  • Re-install the rock-on.

Depending on the rock-on, you might also need to remove the contents of the share you used as the config share for Nginx-Proxy-Manager (either by deleting the files from the command line, or deleting and re-creating the share). I’m not familiar with how this rock-on writes its config, but it would ensure there’s no remnants of the previous (failed) attempts at starting this rock-on; something to keep in mind if you still encounter problems starting it.

Let us know how it goes!

2 Likes