No Devices for installation found issue

Good day Everyone,

I’ve been trying to install the latest version of Rockstor on a Dell Poweredge R250 but I keep on having this issue when I try to install Rockstor.

image

I’ve configured 2 virtual disks as Raid one, accessed the lifecycle controller, launched the deploy os wizard and tried virtually every option to my availability but I still get this error.

Has anyone else experienced this issue or have a possible solution to this problem?

Kind regards

@referee101 dumb question probably, but I assume you also have an OS disk specified in addition to your virtual drives, correct?

And this is on Rockstor 4.x, correct?

@referee101 Hello again.
Re:

Our new installer does have an “ignore drives above” size setting as a ‘saftey’ measure:

So it could well be just that, i.e. if the drives you have prepared are greater than 5 TB they are considered, as a safe-guard, to be more likely data disk members or intended members. It’s a way to help folks not accidentally select a data disk or intended data disk during the install. With the assumption that smaller devices than this are likely to be selected for the system disk.

See the following subsection of our installer howto:
https://rockstor.com/docs/installation/installer-howto.html#select-installation-disk

Use cursor keys to highlight, then the “Enter” key to select. Only devices less than 5000 GB (5 TB) are shown. Larger disks are assumed to be data disks.

Also what @Hooverdan said as we expect a separate/dedicated system disk to install to, in order to maintain system/data seperation.

Hope that helps.

2 Likes

Thank you for your reply.

This must be the issue. The drives I have installed are 8TB drives.
Is there any way to bypass this limitation?

Hi Hoover,

No. I have 4 x 8 TB sas drives configured as VD1 (drive 0 and drive 1 in Raid 1) (Drive 2 and 3 raid 1)
I was hoping to install the OS on VD1.

The server only have enough caddy’s to support 4 drives.

I see that I’m able to build my own custom installer.

I’ll try this apporach with the following line modified to support up to 8TB

kernelcmdline="plymouth.enable=0 rd.kiwi.oem.maxdisk=5000G

I Was able to resolve this issue by modifying the hdd size limitation and creating my own custom installer.

Much respect & appreciation for the feedback

Kind regards
Tiaan

4 Likes