None of my snapshots show

I’ve tried creating snapshots of both OOTB root and home shares, as well as of shares that I’ve later created, but none of them list in the UI. I’ve tried checking and unchecking the visible box, and I’ve tried the read/write radio button in both directions with no difference. I also made sure to use normal names like “test”.

I was able to locate the snapshots in the /mnt2/{pool}/.snapshots/{share}/ directory, so they are actually being created.

Hi seijirou

I have the same problem. Did you find a solution?


@seijirou & @Tom Thanks for reporting diagnosing and confirming this issue.

I have opened a github issue for this and quoted yourselves:-

There have been a number of recent WebUI changes and these are ongoing so looks like this issue is related. I have referenced this forum thread so that it might be updated / linked.

Great support, thanks a lot!


Thanks for confirming. It looks like Rockstor has identified this as a bug.

I don’t have a solution but as a work-around you can still work with snapshots on the command line for now which isn’t too paintful between the btrfs wiki and Google for help.

Yes, definitely a bug in showing the snapshots. You guys beat me to it, but I fixed the bug last night. As @seijirou pointed out, you can create snapshots, schedule them etc… but they are just not visible in the ui. It’s fixed by this commit and we’ll all get the change with the next update in a week or so.

Thanks @phillxnet for opening issue #694. But as it was a minor fix, I did as part of issue #650.

Also, here’s some more information about the cause. As it is obvious, a Share is a BTRFS subvolume and any snapshot of a Share is it’s child and linked back to it’s parent via parent ID and parent_uuid. Perhaps because of the placement of snapshots under pool/.snapshots/… the parent ID is pointing to that of the Pool(BTRFS) and not the correct subvolume of the pool we want. However, uuids and parent_uuids are being mapped correctly. So the above referenced change falls back to uuid check when ID check doesn’t work. I’ve alerted the btrfs mailing list to this behavior, but for now we are good.

@suman That’s a nice find. In the light of your comment I have closed issue #694 and linked it to your recent merge.

1 Like