NoSuchPackage: dmraid

So I ran into this issue with another machine I was trying to install Rockstor on, This is a Asus mother board not sure the model at this point,but it has a onboard raid when more than one disk is installed with the same size so it appears.

I did a little research and found this link

So which version of CentOS 7 is used for RockStor Im running the latest stable version 3.8.13 but looking at the system I see it says 3.8.10 (core)

[root@rockstor ~]# uname -a
Linux rockstor 4.4.5-1.el7.elrepo.x86_64 #1 SMP Thu Mar 10 11:45:51 EST 2016 x86_64 x86_64 x86_64 GNU/Linux
[root@rockstor ~]# cat /etc/redhat-release
Rockstor release 3.8.10 (Core)

Also will the CentOS 1511 be included in the next release of Rockstor? Or is there a work around in the meantime that I can get dmraid installed to get this other machine up?

Thanks in Advance

@kcomer After updates my understanding is that an installed Rockstor system is upgrade to 1511 bar a python package or two where upstream versions caused incompatibilities. But as to the specific version of CentOS 7 on the install iso I’m not sure.

I have done a few successful mdraid on system installs ie 2 (in this case) disks raided and used for the Rockstor system, Mdraid for data disks isn’t supported as we are only btrfs raid types there.

The documentation has a Mirroring Rockstor OS using Linux Raid which has been confirmed as working. This install method however is not aimed at bios raid but generic software raid installs involving the system (though it may prove to be a workaround for using the bios raid). But I have also done bios raid installs which is more akin to what you are asking after as far as I understand it. The bios raid or fake raid installs also rely on the mdraid subsystem due their software raid nature: mostly. And although there was a caveat during the install it did succeed. I didn’t in these installs notice the NoSuchPackage: indication.

On reading your title again you state dmraid where as my experience is with mdraid which on a quick read up seems to be a superset of dmraid. Maybe the same installer caveat applies.

The following forum thread details mine and another forum members finding re this caveate:

I think the /etc/redhat-release file is bogus in this case and seems to have been neglected in the intervening iso releases. I have opened an issue in the rockstor-iso repo for this:
update redhat-release file in etc

Thanks Phill, your reply gave me an idea and I was able to get it installed on this machine with out much of an issue. I first removed all disk except for the Disk I wanted to install Rockstor. It installed with out issues.

Once it was installed I updated the software yum update. then I shutdown the server and reconnected all the remaining drives. I attempted a restart but it hung on the start up so I did a second restart and this time it came up with all drives and I was able to format them.

Also yes dmraid This came from the error report as the reason for the installation failure. I saved the logs and that was given as the reason why it failed so I went with it in the post. Also after reading the other post helped me with the idea to ry to install it with one disk in place.

Hey guys - anyone know if there is a workaround for this yet, that will still enable me to use dmraid?
The device is accessed by the installer, new partitions are created but the installer bombs with the same error message, no such package: dmraid
For whatever reason, no matter how I configure my 1U server, the SATA or SAS drives are not recognised under they are in a raid set configured under the adaptec controller or intel raid controller on board (the raid bios is selectable)
It’s a bit frustrating as had no issues with the RHEL installation I did with the same hardware a few weeks ago - that had no problem installing directly onto my hardware raid.