Odd situation after updating and rebooting rockstor

I had a weird situation that just now. I restarted my machine after updating rockstor. I knew it was done updating since I use the CLI. After rebooting I lost connection to it. I was able to log into it through my PI-KVM and ran NMCLI which stated the my ip was 192.168.1.195/32 when it should be 192.168.1.195/24.

Since I’m using a network bond I pulled one of the two ethernet connections and it did not help

I tried “dhclient -r && dhclient” to pick up a new dhcp lease from my router and it did not help

I was able to get it back to the “/24” when I ran dhclient -r and then dhclient separately.

Now, I can log into rockstor from the browser but I cannot reach any of the rockons.

I restarted my router and switch then toggled Rock-ons off and back on and all is working as it should.

Now I don’t know if this a rockstor bug or a bug on my end. But I thought I would share.

PS Im by no means a network or Linux guru. I’m learning as I go.

1 Like

Now none of my rock ons can reach the internet. Plex cant be reached, radarr does cannot reach the internet either.

I rebooted and It picked up the /32 ip again. Running dhclient -r then dhclient fixes it.

image

So I disabled my Network bond and all the Rock ons are working normal.

1 Like

@Emmanuel_perez Hello again.

Glad you found a work around. Could you say what version of Rockstor this was on?

We may have a bug in our current bonding implementation. It’s not I think been tested much in our new v4 release. And I no longer have access to the hardware I had previously acquired to test this functionality unfortunately. I’ll try and get this sorted again as the bonding/teaming was quite the feature and it would be good to ensure this is good.

Thanks for the report. I’m note sure whats happened here but hopefully this thread will attract attention so we can flesh out the exact issue to address here.

Cheers.

2 Likes

Im on Rockstor 4.1.0-0 Stable.

Thank you, glad to be a part of the rockstor community.

3 Likes