OpenSUSE 15.2 installer build error

I built an OpenSUSE 15.2 VM with nothing extra added, to build the ISO for installation to bare metal.

In trying to build the new ISO following the guide in the on Github, I am consistently getting the following error:

[ INFO ]: Processing: [########################################] 100%
[ ERROR ]: 17:19:21 | KiwiBootStrapPhaseFailed: Bootstrap package installation failed: Repository ‘Leap_15_2_Updates’ is invalid.
[Leap_15_2_Updates|] Valid metadata not found at specified URL

Please check if the URIs defined for this repository are pointing to a valid repository.
Some of the repositories have not been refreshed because of an error.

[ INFO ]: 17:19:21 | Cleaning up SystemPrepare instance

I’ve gone back through to check that I didn’t miss an add repo command or anything. I’ve tried running it multiple times, in case it was just a network blip from my VM to the world. But it hits every time.

I’ve refreshed the repos on the system multiple times.

Any thoughts?

Hi @jcdick1,

The good news is that this is not your fault; this specific repository has been exhibiting this behavior few a little bit now and I’ve seen reports of it across timezones and systems (see on the openSUSE Users mailing list, for instance).
I personally have seen it on my Leap 15.2 desktop too and could successfully refresh the Leap 15.2 Updates repo at times. You could thus try again, hoping you reach the repos at a better time.
An alternative, which I would personally prefer if you are building your own installer, would be to use the corresponding Leap 15.3 profile to your target architecture:

  • Leap15.3.x86_64 (potential for Rockstor 4 ‘re-launch’)
  • Leap15.3.RaspberryPi4 (required for RPi400 built-in keyboard function)
  • Leap15.3.ARM64EFI (N.B. Ten64 compatibility awaiting mcbridematt repo update)

Although I have not tested that myself, I have not seen reports of issues with any of the Leap 15.3 repos so you should have a much better time with it. It would also give you the current Leap base, so that’s another benefit.

Hope this helps,

1 Like

To use the 15.3 profile, I would simply follow the same HOWTO, but change the “2” to a “3” in the final kiwi command, correct?

@jcdick1 Hello there.
I can chip in on this one:

Yes, just specify the 15.3 Profile. For instance, assuming you are build for an x86_64 type installer you would use the Leap15.3.x86_64 Profile i.e. in the “–profile=Leap15.3.x86_64” bit.

Strictly speaking it is best to use the same or newer Leap version, relative to profile, in the host machine but Leap 15.2 host (VM) can quite happily build a Leap 15.3 installer. This may not be the case going forward but should be fine for now.

Note however that if you use the boxbuild method then the linux distro and version doesn’t much matter as long as it’s fairly recent. This is because the boxbuild method creates it’s own VM with an appropriately versioned Leap os. But given you already have the Leap 15.2 installed just go ahead and build within that using the non boxbuild method and you should be just fine.

Hope that helps.

1 Like

Being virtualized, I just deleted the VM and recreated and reinstalled 15.3 and now have


in my kiwi-images directory.

So I guess that worked. Now I just need my actual storage server to arrive.