Openvpn Easy-RSA error [solved]

sorry, didn’t know the pem and pass phrase had to be the same.

hi everyone, very need to this and this is my first post. i’ve installed latest version on a spare dell laptop to play with and everything went fine. now i would like to install openvpn server so i can access rockstor from outside my lan (i understand from reading that this is a necessary step).

installed the rockon, have set the host name (i.e. asdfg.hj) and port in configuration, then when i get to the ssh bit i found this Easy-RSA error. basically


i set PEM pass phrase, a Common Name and a pass phrase for the private key. First 2 steps go fine, after i type the private key i get the error. tried several times but problem persist.

here is the output. any help would be appreciated. this distro really rocks and would like to make the best out of it.

DH parameters of size 2048 created at /etc/openvpn/pki/dh.pem

Generating a 2048 bit RSA private key
writing new private key to ‘/etc/openvpn/pki/private/rockstor.key.XXXXaAIIpI’

Using configuration from /usr/share/easy-rsa/openssl-1.0.cnf
Enter pass phrase for /etc/openvpn/pki/private/ca.key:
unable to load CA private key
140293378018252:error:06065064:digital envelope routines:EVP_DecryptFinal_ex:bad decrypt:evp_enc.c:531:
140293378018252:error:23077074:PKCS12 routines:PKCS12_pbe_crypt:pkcs12 cipherfinal error:p12_decr.c:108:
140293378018252:error:2306A075:PKCS12 routines:PKCS12_item_decrypt_d2i:pkcs12 pbe crypt error:p12_decr.c:139:
140293378018252:error:0907B00D:PEM routines:PEM_READ_BIO_PRIVATEKEY:ASN1 lib:pem_pkey.c:142:

Easy-RSA error:

signing failed (openssl output above may have more detail)

@satello Welcome to the Rockstor community.

I would first ensure that you have fully configured the openVPN Rock-on/docker. Hopefully our OpenVPN Server Rock-on doc entry will be of use.

Hope that helps, at least as a start.