OpenVPN Install Issue/Question

Okay so I’m really confused here. When I attempt to install the OpenVPN Rock-on by following the Rockstor Documentation, when I get the the step to actually install I notice a something different compared to the documentaton.

The documentation shows the port and server info

Buy when I do the exact steps I get this

It never show the Server info.

I’m using No-IP as a trial to see if I can get it working, I have opened the port on my router and still nothing.

Any thoughts,


I just recently set up the OpenVPN Rock-On on my box. I did not run into the issue you are describing (i.e. I did see the server name entry screen and then in the summary page before installation it would show two rows (port and server). Have you tried using a different browser to see whether it might “just” be a display issue?

Also, which version of Rockstor are you running?

Btw, I’ve been using No-IP (free version) for this, and it works very well I must say.


I’ve tried on Mac,Windows with Chrome and Firefox.
I’ve opened port 1194 on my router and set up my No-IP info in my router. So if I type in my No-IP Hostname shouldn’t I be able to connect to the Rockstor on that port?

Also when I’m using the set up wizard and I mouse over the tool tip, it says “Your Server public IP address of FQDN” Isn’t that the No-IP sever address?

Every time on the last screen before I click to setup the the Rock-On, the server field never shows up. I even typed the public IP address and still nothing…

Very weird.

Oh and Im running Rockstor version 3.9.1-16

Hi @William_Wright,

Are you trying to hit port 1194 in a browser?

If so, that is not going to work. The OpenVPN rockon is for connecting an OpenVPN client to, and it serves a much greater purpose than simply allowing access to the rockstor ui, it gives you a remote (secured) path into your network remotely.

Otherwise, please ignore the above and instead confirm that you’ve run the init PKI and client profile generation scripts, and imported the client profile into your VPN client.

Also, verify that the docker container has started and port is listening on your server via terminal:

docker ps|grep -i vpn
netstat -tulpn|grep 1194

Like Haioken mentioned, the PKI stuff has to be done as well, although, it would be interesting to know what happens if you’re not even able to specify a “host” (like your No-IP address)…

In any case, if you want to check out your configuration on the docker image you could get to it like this in SSH:

execute command:
docker run --rm --volumes-from ovpn-data -it busybox sh

the configuration file is then found in /etc/openvpn in the openvpn.conf file (note, that nano does not exist in the image, but you can use vi to edit/view the file).

Not being an expert in OpenVPN, I found the keys in my config file referencing a portion of the public (i.e. No-IP address) server in there.

Haioken - When I do as you suggested it states that “netstat:command not found”
So I’m not sure what that means.

Hooverdan - in /etc/openvpn, this only thing in that directory is another directory? named “ccd”
No config file at all?

Any thoughts,

Mhm, looks like it’s not completing the configuration as it usually would … this is what I have:

Fundamentally, I think the fact that you don’t get a place to enter the Host Name is the underlying issue. And if these things that Haoiken mentions:

are creating error messages, something is messes up during the RockOn setup …

And this is where my “in-depth” knowledge unfortunately ends. I had other RockOn issues in the past (plex and Emby), for which my last resort was to uninstall the Rock-Ons, disable the RockOn service, and configure a new RockOn service share, etc. After that, my other issues went away. Before you do the nuclear option (which is not guaranteed to work for you), I hope somebody else has way more experience in this area.

I assume, in your logs you don’t find error messages, right after (or during) you attempted the setup (rockstor.log under /opt/rockstor/var/log/? Or errors when you hit the refresh button on the rockon library (to ensure that the metadata and anything related is refreshed?

Fresh out of ideas right now.

Yep I’m stymied here, I re-ran the vpn install and it failed as before so I checked the rockstor.log file and nothing, only info was from some network config error back on December 16th. So I have no idea what to do here.

Don’t I have to initial the PKI after the installation?

okay so I finally got something in the log file

[24/Dec/2017 14:49:03] ERROR [storageadmin.views.rockon_helpers:124] Error running a command. cmd = /usr/bin/docker run --n
ame ovpn-data -v /etc/openvpn busybox. rc = 125. stdout = [’’]. stderr = [’/usr/bin/docker: Error response from daemon: Con
flict. The container name “/ovpn-data” is already in use by container e581ec87f427a53ff3af24c783a5e07863a9fe53e7ed082b02df4
b18b889c104. You have to remove (or rename) that container to be able to reuse that name…’, “See ‘/usr/bin/docker run --he
lp’.”, ‘’]
Traceback (most recent call last):
File “/opt/rockstor/src/rockstor/storageadmin/views/”, line 121, in install
File “/opt/rockstor/src/rockstor/storageadmin/views/”, line 230, in openvpn_install
File “/opt/rockstor/src/rockstor/system/”, line 121, in run_command
raise CommandException(cmd, out, err, rc)
CommandException: Error running a command. cmd = /usr/bin/docker run --name ovpn-data -v /etc/openvpn busybox. rc = 125. st
dout = [’’]. stderr = [’/usr/bin/docker: Error response from daemon: Conflict. The container name “/ovpn-data” is already i
n use by container e581ec87f427a53ff3af24c783a5e07863a9fe53e7ed082b02df4b18b889c104. You have to remove (or rename) that co
ntainer to be able to reuse that name…’, “See ‘/usr/bin/docker run --help’.”, ‘’]

it seems, for some reason you have a paused installation of the RockOn. If you did a de-installation before via the Rockstor UI, it apparently did not remove that container for OpenVPN.

what’s the output of: docker ps -a. Does it show the OpenVPN as stopped?

Since you’re attempting a reinstall (well, a correct first install :slight_smile: ) of it you could probably remove the conflicting container using:
docker rm e581ec87f427a53ff3af24c783a5e07863a9fe53e7ed082b02df4b18b889c104

and then attempt to do the installation again.

Being mainly a windows person, I would of course say, after the removal, reboot the server :slight_smile:

I actually did that and for whatever reason after removing that container it locked up the system? So I just reinstalled Rockstor. On a side note and probably very much the cause of this issue was my network setup.

I “thought” I disabled the DHCP function of my ISP router but did not so I had a double DAT issue going on with the ISP router and my actual router. So to no surprise fixing that fixed the issue and it has now successfully installed and I followed the extra but necessary additional steps and all seems fine. of course now I have to figure out how to actually use the VPN, ha ha. Fixing the double NAT issue also fixed Plex from not being accessible from outside my network.


1 Like