OwnCloud Install takes forever

On the second try of installing OwnCloud. First attempt overnight failed, unable to gain insights from the logs. Have restarted the install after a zypper update of the system, been running all day, no success yet.

I had previously installed NextCloud, which took a trivial amount of time, however it being version 25, none of the office software worked, as in no way to edit a docx document other than downloading it locally. It has been removed

Did get a SFTP Service going, along with Samba, so really not sure what is going on.

I did search this forum for hints, but most posts are pretty old, so any guidance would be appreciated. Thanks

@marcsitkin, welcome to the Rockstor community. I don’t have a solution for you, I tried the installation myself yesterday, but was also running into problems (shows as installed, but it restarts periodically and I am not successful in getting through the login. This might be an issue in general, since the underlying docker container is fairly old now and hasn’t been updated in 3 years from what I can tell).
The OwnCloud Rockon actually has some custom Rockstor work behind it, so not sure whether that has been impacted by the move to 4.1 on OpenSUSE.
What do you see in the docker logs during your install if you don’t mind sharing? Also, I assume, you’re using Rockstor 4.1, correct?


@Hooverdan @Flox
Given it’s current state and the lack of community engagement on this Rock-on, maybe it should be marked for removal. If there is insufficient will/resource to maintain it, maybe it should be deleted as per our following doc section:
Deleting a Rock-on

as it is super frustrating all around when they fail horribly like this.

And an update of NextCloud would seem the way to go on this front.

@Hooverdan Re:

Linking for context:

Or impacted by changes in the docker image used.

I don’t particularly like these ‘special’ cases. And will be please to see the last of them removed. Currently there remains custom work for the openvpn and owncloud Rock-ons only, from a quick look.

Hope that helps.


@phillxnet, agreed on its removal.