OwnCloud Rock-on

First off, thank you to @suman and all the other very kind contributors who have given their time and energy into creating and improving this project. I have benefited greatly and am quite enjoying having an economical and powerful NAS thanks to Rockstor. Not only is the NAS responsive within my local network, I have also managed to enable Transmission and OpenVPN quite easily.

Second, please bear with me as I probably have considerably less Linux knowledge than many of you here. We’ll see if I confirm my cluelessness with what I write below. With that out of the way, let’s get to the point…

I believe I’m running into the same issue that D_Jones above is. I’ve installed ownCloud in the recommended fashion, meaning that I have created the recommended shares in Rockstor in advance (owncloud-config, owncloud-data, and owncloud-db) and they have been mapped properly.

ownCloud appears to start, but clicking the “OwnCloud UI” button leads to a page that fails to load (Firefox error message: “Firefox can’t establish a connection to the server at”)

Now, here’s where I aimlessly investigate. I hopped onto the NAS via SSH and repeatedly spam docker ps, which reveals that the image pschmitt/owncloud is repeatedly restarting. I see that it’s running /usr/bin/run.sh. I check docker inspect owncloud and see

"Id": "3ece6f99b8385633ca54f143179a33294506ebbc179c6531d6e5a81dc25f8739",

…so I try running


which results in

Creating autoconfig.php... /mnt2/rockon/btrfs/subvolumes/3ece6f99b8385633ca54f143179a33294506ebbc179c6531d6e5a81dc25f8739/usr/bin/run.sh: line 55: /var/www/owncloud/config/autoconfig.php: No such file or directory

But returning to docker inspect owncloud, I see that

{ "Source": "/mnt2/owncloud-config", "Destination": "/var/www/owncloud/config", "Mode": "", "RW": true },

…which is not unexpected, as it appears things are mapped properly. In addition,

[root@nas config]# ls /mnt2/owncloud-config autoconfig.php

So autoconfig.php seems to exist where I expect it to be? I’m at a total loss. Any idea what’s going on?

I know I’m making an assumption here that running /mnt2/rockon/btrfs/subvolumes/3ece6f99b8385633ca54f143179a33294506ebbc179c6531d6e5a81dc25f8739/usr/bin/run.sh achieves the same result as starting ownCloud via the web UI. The reason I wanted to run that file is to see the errors it spits out. Assuming the result is the same whether I manually run it or try to start ownCloud via the web UI, why is it not able to find autoconfig.php?

After installing owncloud from the rock-ons repository and hitting the OwnCloudUI button, I get this issue with the thrusted domains where I should adjust the config.php accrodingly. I’ve found the config.php under my owncloud-config share and looked up with nano…add…and it worked.

1 => "',

Sorry, I was not able to find the delete button of an entry - thx

Beside my previous message (see above)…has anybody tried to install owncloud from the Owncloud download webpage and the dedicated sources for CentOS?
I’ve good experience in using this for Openmediavault before…

CentOS_7 owncloud-9.0.1-1

Run the following shell commands as root to trust the repository.

rpm --import https://download.owncloud.org/download/repositories/stable/CentOS_7/repodata/repomd.xml.key
Run the following shell commands as root to add the repository and install from there.

wget http://download.owncloud.org/download/repositories/stable/CentOS_7/ce:stable.repo -O /etc/yum.repos.d/ce:stable.repo
yum clean expire-cache
yum install owncloud

I ran into the same issue: when hitting the WebUI button I get a connection error.

Since @D_Jones reported the problem one month ago I’d like to ask if @suman had time to like into this.

I am rebuildin the Owncloud rock-on, but have run into the issue of the following error:

‘unicode’ object has no attribute ‘get’

Does anyone know what this means? im using the official owncloud image this time.@suman: anything special changed during last updates?

Log output from rockstor/var/log/rockstor.log:

Traceback (most recent call last):
File “/opt/rockstor/src/rockstor/storageadmin/views/rockon.py”, line 105, in post
self._create_update_meta(r, rockons[r])
File “/opt/rockstor/eggs/Django-1.6.11-py2.7.egg/django/db/transaction.py”, line 371, in inner
return func(*args, **kwargs)
File “/opt/rockstor/src/rockstor/storageadmin/views/rockon.py”, line 273, in _create_update_meta
self._update_env(co, c_d)
File “/opt/rockstor/src/rockstor/storageadmin/views/rockon.py”, line 338, in _update_env
for k in self._sorted_keys(cc_d):
File “/opt/rockstor/src/rockstor/storageadmin/views/rockon.py”, line 309, in _sorted_keys
idx = ccd.get(‘index’, 0)
AttributeError: ‘unicode’ object has no attribute ‘get’

I believe the error is to do with localtime file getting overwritten in run.sh script.
i get this error when i run

docker start -a owncloud

Setting timezone to UTC… ln: cannot remove ‘/etc/localtime’: Device or resource busy

you can check and see, I bypass it by editing the run.sh so as not to create a link to that file
ln -sf “/usr/share/zoneinfo/$1” /etc/localtime
ln -sf “/usr/share/zoneinfo/$1” /etc/localtime2
Restart the RockOn and It will work

am sure the time will be wrong now, but at least I can test the owncloud.


Interesting! I’ll check out my setup when I have a moment. Thanks for giving me an angle to pursue.

Just wanted to say that I was able to get my instance of ownCloud running thanks to your suggestion. Appreciate the tip!

Good that it worked for you, hopefully there will be fix for this in the updates

Thank you for sharing your workaround, I had the same problem. Did you open a bug report about this issue?

Will there be any automatic upgrade to owncloud 9 from this rockon?

Where is run.sh so I can modify it?

Try “find . -name run.sh | grep Owncloud”

I think that will show you a bunch of run.sh files. They’re all identical, but only one of them is the one that runs when Owncloud starts. I do not know how to differentiate between them. They’ll all have a long directory name with a ton of random letters in them though.

I decided to use the new Owncloud package that automagically appeared in the Rock Ons list. Now if I could only find out how to add existing shares to Owncloud.

This should be fixed now. You may need to refresh by hitting the update button.

Thanks! That works well now. The only issue I have at the moment is connecting to Owncloud via SSL. I get the following error in Firefox.

An error occurred during a connection to augustus.ribbed.us:8087. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

I would use Owncloud to access my share outside my network, but not without SSL, so as of now, Owncloud sits.



I’m trying to update a a trusted domain. Could someone please lead me the location for the config.php file that I need to add to. I see the trusted domain errors in owncloud (local) so my connection is good. Pretty sure i just need to add my ddns addy as trusted.

Thanks for your time and help

Hello Mceed!
The location in my system is /mnt2/myowncloudconfigfolder/config.php

The config folder is the one you created when you installed the rockon. Hope this helps!

1 Like

I will go more into detail how i fixed this problem for me. Basically I combined some of the advice scattered around these forums (thank you guys)

  1. docker ps
    look for <containerid> for “pschmitt/owncloud “/usr/bin/run.sh””

  2. docker stop <containerid>

  3. find /. -name run.sh
    provides you with a list of all available “run.sh”, look for the ones containing your <containerid> in their path
    example: …/subvolumes/<containerid>54f154df5454h4564ds/usr/bin/run.sh, reduced the amount to 4 files for me

  4. sudo nano each of these files and search file for “localtime” (ctrl + w)
    example: sudo nano …/subvolumes/<containerid>54f154df5454h4564ds/usr/bin/run.sh

  5. change “localtime” to “localtime2”, save and exit file (ctrl + o, ctrl + x)
    for me it was file “…/usr/bin/run.sh” (not “…-init/usr/bin/run.sh”)

  6. docker start <containerid>

I’m having the same issue, but I cant find the run.sh file to edit. Doing the find just tells me there’s a file system loop, and there isnt a config.php file in the config share, only an autoconfig.php file. Should I make the edits in there?