Can not install OwnCloud RockOn (3.8-14.02)

I am trying to install OwnCloud RockOn on 3.8-14.02 but the install fails with the following message:

[07/Jul/2016 14:28:15] DEBUG [storageadmin.views.rockon:84] Rockon(OwnCloud) is in pending state
[07/Jul/2016 14:28:15] DEBUG [storageadmin.views.rockon:84] Rockon(OwnCloud) is in pending state
[07/Jul/2016 14:28:31] DEBUG [storageadmin.views.rockon:84] Rockon(OwnCloud) is in pending state

I looked in the other thread [OwnCloud Rock-on - #8 by dilipsdil] but couldn´t find anything there that is applicable to my errors above.

What’s in the logs?
ssh into the box, and hten:

cat /var/log/messages|grep OwnCloud
journalctl -u docker.service

I’m getting the same thing on 3.8-14.03, I’m not a docker expert, but it looks like the owncloud container is getting caught in some sort of reboot loop

[root@rockstor log]# docker ps
CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS                          PORTS                                     NAMES
273948e54b12        pschmitt/owncloud   "/usr/bin/"        2 minutes ago       Restarting (1) 44 seconds ago   80/tcp, 443/tcp,>8085/tcp   owncloud
dfcc5c291950        postgres            "/docker-entrypoint.s"   28 minutes ago      Up 28 minutes                   5432/tcp                                  owncloud-postgres

along with

[root@rockstor log]# docker inspect -f "{{ .RestartCount }}" owncloud

So I’m not sure what’s going on there. The hosts journalctl is empty of any owncloud errors and rockstor.log only contains the message saying that it’s in a pending state. Trying to use docker’s logs I get

[root@rockstor mnt2]# docker logs owncloud
"logs" command is supported only for "json-file" and "journald" logging drivers (got: syslog)

So there’s got to be a way to view the syslog format of the logs coming out of there.

1 Like

I changed the owncloud logging driver to journald and found the following in there

Jul 08 11:15:47 rockstor docker[14296]: Creating autoconfig.php... Done !
Jul 08 11:15:47 rockstor docker[14296]: Updating nginx.conf... SSL is enabled Done !
Jul 08 11:15:47 rockstor docker[14296]: ln: cannot remove '/etc/localtime': Device or resource busy
Jul 08 11:15:47 rockstor docker[14296]: Setting timezone to UTC...

Which makes me think it has something to do with the “-v /etc/localtime:/etc/localtime:ro” parameter that is passed into the owncloud container.

I know you mentioned that you looked into this in your original post, but it does look like the same error others and myself have had recently when trying to install the ownCloud Rock-on. I use the fix described below and it worked for me:

It may be worth giving it a shot.

1 Like

You can still test to mount /etc/localtime read-only, e.g.

-v /etc/localtime:/etc/localtime:ro


Or check the env moethod mentioned in the issue link.

Looking through all of the files I didn’t find any that had “localtime” within it…

I am not really familiar how RS integrates docker daemon / calls the docker client; but you’ll have to add this as a mount command in the OwnCloud .json… which is stored where locally, when RS pulls it from the Rock-on hub?

You can try to copy the offical .json to /opt/rockstor/rockons-metastore/ and edit it there, then OwnCloud will show up as a local Rock-on. Will probably get some errors about “already exists” first, when you do not clean any references for the old one. EDIT: if that meta dir isn’t on your machine, just create it as root.

(Disclaimer: i do not use the RS Rock-on UI, i solely manage docker containers via cmdline.)

To answer your question first, have you tried the same command as detailed by @Noggin but without grepping for ‘owncloud’?

find /. -name

If I remember correctly, all the files found with grepping ‘owncloud’ were not the correct ones (although identical) either. But with the above command I could find and edit the files that did include the call to ‘localtime’ (it was close to the last lines of the given file). I don’t have access to my RS machine right now so I can’t give you the exact path to this file on my system right now but this should be enough for you to find it and fix it.

That being said, @f_l_a’s solution does seem a lot more robust to me and may even survive a reinstall of the Rock-on. My guess would be that the .json file is stored in the rock-ons root share (if created).

Let me know how it goes and if you need additional details and I’ll try to share with you how it is on my system later.

Thanks @Flox.

…maybe he can also edit the container’s config (actually the host config) like i described here. Just some minutes ago i altered one container’s restart policy accordingly.
The container should have been created via RS’ docker run ..., so all you need is to fix some bits via cmdline to get it up & running.

(And ui-for-docker is a good management UI, in the meantime, before our good RS contributors, maybe with some help from us more or less observing people, will have a solid plan forward at hand. And it will come, i’m sure.)

I replaced “localtime” with"localtime2" in most copies of and it looks like everything started up for me.

I don’t know if this solves the issue for @CrazyFin but thanks @f_l_a and @Flox, it got mine up and running.

I can verify that Tyler Williams solution works.