(Partly Solved) Duckdns instal wizard entry fields

Hi
Once again I need some help with a Rockon
I intend to add the DuckDNS rockon in order to provide access to my media collection from a remote location.
I think I have the correct responses for the first three entry fields of the install wizard i.e.
DuckDNS%20Instal%20Screen
UID and GID from the user and group tables on the Rockstor system tab.
Subdomain(s) this would be the desired name(s) for the Rockstor for remote access.
i.e
http://dXXXmedia.duckdns.org plus 4 others in comma separated format should they be needed.
Token
This is the troublesome part.
Is a visit to the duckdns website required for registration of subdomain(s) and retrieval of token for both to be subsequently entered into the rockstor Duckdns instal wizard?
OR
Something else.
I have tried to enter the first three fields to see if a token appears in the last field but no dice there.
So
How is it done can anybody help with this?
(I could have possibly completed with a visit to the Duckdns site but wondered if it might have caused a “Double Entry” somewhere in the process and achieved lock out in some shape or form :cold_face:)

Hello there, @Mike-B,

I have not used DuckDNS in a while so others might correct me but here’s what I think based on previous experience and the image’s documentation.

Yes. Linuxserver.io’s documentation reads:
https://docs.linuxserver.io/images/docker-duckdns#application-setup

  • Go to the duckdns website, register your subdomain(s) and retrieve your token

Once you create your account, you will be provided with a Token, which you can then enter in the Rock-on install field.

One note regarding the subdomains:

Their documentation (https://docs.linuxserver.io/images/docker-duckdns#environment-variables-e) reads:

SUBDOMAINS=subdomain1,subdomain2

As a result, I would skip the http part and only put in the subdomain (part before the .duckdns.org). In your example that would be dXXXmedia.

Hope that helps,

2 Likes

Thanks @Flox
Nothing else to do but give it a spin.
Will let you know.

1 Like

The Duckdns registration was completed without hilch and the token copied, all relevant fields in the Rockstor wizard were completed and the next button selected, the Rockon seemed to install,
However, not really knowing what the result would be but hoping that access to the Rockstore would be enabled in some way by using a mobile phone (without wifi internet connectivity from the Router) I get:
This site can’t be reached
XXXX.duckdns.org took too long to respond
I understood that connection through duckdns was available with very little delay hence the feeling something hasn’t quite worked.
Any ideas

Thought I should have a go at some fault finding to get this problem sorted.
1 Checked that all the registered data with DuckDNS had been transferred to the Rockon.
Great first mistake, comma separated domain names separated with a period :cold_face:
Corrected that one.
2. Opened CLI in windows and pinged the duckdns domain name, all good there (3ms response).
3. Tried to access the ip address both internal and external, reply being:
My-IP unexpectedly closed the connection.
As the router has just been changed to a virgin Hub 4 due to Hub 3 failure, the next stage is to investigate the hub 4 settings.
Will let you know.

2 Likes

PS
Am I correct in thinking the DuckDNS Rockon does not require a Config Share.

Yes, this is correct.

Almost there.
Jellyfin is now available from outside of the private network but not through DuckDNS. It will only work by entering the public address in numerical format i.e http://xx.xx.xx.xx:8096.
Firstly
Having spent hours traipsing through pages of guidance offered from a variety of sites and completed a range of tests I have come to the conclusion (but could easily be misguided here) that Virgin Media (VM) will not allow DNS servers through the VM system as they would like to charge their broadband customers for the privilege by means of a business account providing a static ip at extra cost.

I have come to this conclusion from tests carried out using DNS checker with the following result.
DNSChecker
Further investigation in to the three issues shown in the DNS checker revealed nothing for dnsbl.sorbs.net or dul.dnsbl.sorbs but dnsbl.spfbl.net revealed this-
DNSChecker-2
S![|893x408](file:///C:/Users/mbrig/AppData/Local/Temp/lu7180730ckd.tmp/lu7180730cmx_tmp_1c7784ba8380bffb.jpg)
Secondly
Browsing around in the new VM Hub 4 I notice that the port forward (PF) for the Rockstor box has been automatically transferred from the Hub 3 (with which PF was readily available) although, whilst having a Port Forward section within the Hub 4, all actions are not available (greyed out) so cannot the rule cannot be deleted.
Am I correct in thinking that Jellyfin does not require PF?
During the browsing session I came upon the DHCP, this nagged me to investigate further, hoping that this could be part of the solution, hence, a rule was made to maintain the Rockstor box internal ip as a “static” ip (192.168.0.24).
Having done all that I tried to connect with duckdns.org, as expected, still being refused, then with a flash of something to the brain, the public ip was tried with the :8086 port for Jellyfin and hey presto we had lift off.
Reading through the VM community posts, it seems that VM rarely change the public ip so hopefully we have a part solution, already tested with an internet connection some 14 miles away with Jellyfin media found fully accessible.
Anyone have a similar experience and found a workaround as in the future I would like to host a family website without having to use the numerical format in place of a domain name.

1 Like

@Mike-B Helllo again.
Re:

Nice.

You are likely already there, but internal IPv4 addresses such as 192.168.. or 10...* are not accessible on the internet, they require the resident/edge router to expose them to the internet, or port forward some ports on them to the internet exposed IP that is on the red (internet) side of your own router. And as you state some internet providers will further restrict what you can expose. Email server ports are a favourite for them to block for instance. Irrespective of what you ask to be exposed on your own equipment.

There are others here far more knowledgeable than me in this area however.

As far as name to number resolution, a simple ping to a name should return it’s associated number. But this arrangement often relies on client side software (i.e. running in a Rock-on or natively on the Rockstor host OS) to ‘shop-in’ your own public number on a regular basis. That is what you are attempting to setup here. So remember that just pinging the dynamic name should given the number it is supposed to resolve to. It may not actually receive an answer but that can be down to a variety of reasons as you are finding out.

Again this is not a strong area for me so just chatting really.

Take a look at the commands “dig” and “dnslookup” also. They allow you to investigate what the world dns system or a specific dns server, knows of domain names, dynamic or otherwise.

Hope that helps.

1 Like