Permission denied when updating Syncthing from its webGUI

I installed Syncthing Rockon and everything seems to be running ok. Haven’t tested it yet but there is a nagging issue present. I keeps giving an update error all the time.

2017-02-18 19:44:20: upgrading: open /go/bin/syncthing567596881: permission denied

I searched and the closest I have come to an answer seems to be in;

The problem seems to be a permision’s issue and since I don’t know were syncthing is installed and docker for that matter I have hit a stone wall.

Can anybody help??

Could not helpbut to try if what worked for embyserver update also worked with this rockon. From Emby plays hard to reach

@Flox 4d
Glad it’s working now @undertakerjimmy !

To update the Emby Rock-on, you can follow the instructions on the docker hub page.

Personally, I do it manually on the command line with the following:
docker exec embyserver update

Contrary to what is mentioned on the page I linked above, the name of my docker image is embyserver and not emby-server but you can doublecheck that by running docker ps on your own machine.

Depending on the update and hardware, it can take up to several minutes but it works.

Hope this helps!

So I tried this:

Open to suggestions.

I found this on the syncthing forums

wweich Community MVPSep '161

The user who runs Syncthing needs to have write permissions for the folder where the binary is to create a temp file and replace the Syncthing binary.

It came from this Topic:

This seems to be the answer, but can anybody show me who would be the user… admin? So far I haven’t found where syncthing is installed and how to replace the binary. I’ll keep digging…

Syncthing is now v0.14.10 and want’s to update to v0.14.23. There must be a way to upgrade, the rockons repository gives no clues. As fascinating as the docker might be, it adds another layer of complexity to the application.

Was anyone able to update Syncthing? If so, care to share. Thanks much

i was able to upgrade by changing the owner (chown) of the bin directory (…/go/bin) where syncthing file is under, to the user used to login (admin in my case).

@goohlie how did you get to this folder? Also can you give me the full path? Thanks

well its different for every setup so u have to use find command ( find / -mindepth 9 -name “syncthing” ) and then pick a subvolume with the most results (in my case e734…)

now do chown -R (user):(user) /(path to …go/bin) thats all to it

Will try. Thanks much

@goohlie that did it. thanks for you help

@goohlie Thanks That did it!!! Finally