Plex Docker not running

Hi all,

I have just installed rockstor (3.9.1-0) for the first time and everything was going smoothly until I tried to get Plex going.

Unfortunately the docker just keeps going around in circles showing status ‘Restarting (111) x seconds ago’ as seen when using ‘dockerps’

I have tried using tail -F /opt/rockstor/var/log/rockstor.log while trying to run the rock-on, this file wasn’t written to once…

Tried both ‘latest’ and ‘plexpass’ versions to no avail, and using the UID/GID numbers and words (plex/plex and 1001/1001) during installation for the user to run it… alas… no luck…

Does anyone know about any current issues affecting the ability to install and run this Rock-on?

Many thanks

I just tried to install the Plex rock-on on 3.9.1 by curiosity, and it seems to install and run fine for me.

Maybe you could try the following to get some logs, and then turn on the Plex rockon on the webUI.
docker logs -f
journalctl -fx

Thanks heaps for the reply. I actually got it going about 30 mins ago now. Turns out the docker image was no good, either a download issue or using ‘latest’ has a problem… when using ‘plexpass’ it worked but probably just coincidence…

I just uninstalled plex (for the n’th time) and deleted the image, reinstalled (so it downloaded a fresh image), and it magically worked!

Glad to read that!
FYI, u used the “latest” tag for my test install and it worked, so like you said, something could have happened during the image pull.