Plex installation setup

I setup a new Rockstor installation (using existing BTRFS disks). I added the Plex rock-on (adding a plex uid and gid, and data/config shares). Plex used to work on the older setup.
When I go to the Plex UI (through the Rockstor webUI by IP number - not rockstor.local), I login, but I don’t see the option to setup server in docker. If fact, when I click “your media”, I am presented with the option to “Get Plex Media Server.”
How do I resolve this (i.e., get to the setup server page)?

@bhp, were the shares you specified for config/data the same ones as on your old installation (i.e. on your existing btrfs disks)? Or was the intent to set up Plex all anew (i.e. new config share, but keep existing data share, etc.)?

The shares were the same (config/data, and media). I just changed the boot disk (with updated Suse & Rockstor).
Other info:
When I installed Plex I didn’t get an authentication token.

mhm, interesting. when I did a reinstall of Rockstor last week and re-set up Plex (using all the original config settings) it worked seamlessly. The login would go through and the server was up and running (no “claiming of servers”) required.

When I go to “” (in my browser [Chrome]), I’m forwarded to “Plex…[long URL)”.

That page says “Plex Web would like to sign in to your Plex account” and the message “This application is at and is not hosted by Plex. Continue only if you recognize this server and wish to grant access.”

I sign-in and sometimes I get “Not authorized You do not have access to this server.” If I sign-off and try again, sometimes I get to a regular Plex page (showing me logged-in). If I click on “Your Media” (on the side menu), I’m asked to “Get Plex Media Server” (which takes me to “Media Server Downloads | Plex Media Server for Windows, Mac, Linux, FreeBSD and More”.

I hope the above description is clear! It doesn’t make any sense to me!

I am wondering whether it’s related to something that was reported yesterday for the plex container, albeit for a synology environment …

not that this currently helps you in any way … maybe you can try an installation of an older tag, like 1.31.2 instead of latest to see whether that makes a difference. If it does, the above reported issue might be related …

1 Like

I gave up. I deleted the data/config shares and reinstalled Rockstor with a different servername. I then installed Plex with a different email address. Yeah, overkill, but it works now.
All good. Thanks for your time.

1 Like