Plex Media Server not able to share online

Not sure what happened.
I setup my Rockstor a couple of days ago on some diffrent hardware. and worked great. Plex was fine and everything.
Then I needed to rebuild cause that hardware I needed to use it for something else.

Anyway I got it reinstalled I followed the same steps. at least I think I did. But for some reason it won’t connect the NAS to the cloud like it did.

The only thing I did diffrent was I updated the software after install. And last time I didnt update till after I set everything up.
this is making me want to trash this and buy a NAS box but I really didnt want to do that. I liked using these free options.

@Bizquick2k Welcome to the Rockstor community.

Given your title I’m assuming you just mean the Plex aspect of remote access, ie you go to and sign in but don’t see your new build as accessible. This could be because you router still has the old info setup via uPnP and your new build, having a different network card / LAN IP address isn’t being granted the port forward as it’s already taken by the previous instance. You could try re-booting your router and it may well be a good idea to go into the Plex UI again and check on the server setting re remote access and maybe re-applying your Plex pass credentials there. I’ve also had to resort to the manual setting approach on occasions as some routers are intermittent / buggy in their handling of uPnP.

Hope that helps and let us know how it goes. Pretty sure this is not related to the software updates though. But do keep in mind that after some updates we have had docker issues, which is how Plex is run so always worth a reboot after updates, especially the Rockstor ones (this is currently know behaviour and is a bug of sorts).

One thing that helped me is to set the port number to a fixed/static in the plex setup.
Sometimes I found that it tried to use a different port and that did not work well with docker.

1 Like