Plex Media Server Rock-On not stopping [Solved]

I have run into a weird problem with my Plex Rock-On / Docker.

When I go into the Rock-On’s section I get this picture:

This goes on for ever, and across reboots. Note that the Rock-On service switch on the left is replicating itself. If I hit update I’m sent to the All categori. Turning the Rock-On service off and then on doesn’t help either.

I have tried stopping plex through the command line “Docker stop Plex”, and starting it again “Docker start Plex” the commands do not error out, I just get the answer “Plex”.

But Plex is definately not working.

I think the error came when I turned the Plex Rock-On of, and then turned Rock-On itself off, before the interface showed that Plex was stopped. Perhaps something went wrong.

Is there a way to reset the Rock-Ons?

There could be an improvement we can make here. What’s the output of this command: docker ps

With Rock-on turned off:

Get http:///var/run/docker.sock/v1.19/containers/json: dial unix /var/run/docker.sock: no such file or directory. Are you trying to connect to a TLS-enabled daemon without TLS?

With Rock-on turned on:
71cbb097a274 timhaak/plex “/” 2 days ago Up 6 seconds plex

A question:
Is docker like a virtual machine? Would it be beneficial to enable virtual mode in the motherboard bios?

Ok, with rock-on service turned on, it automatically starts plex which is what I wanted to see.

Can you add a screenshot of how your rock-ons web-ui looks like now? You might want to refresh the browser(Shift + ctrl + r). Also, could you use Chrome if you are not already?

you are right about docker. I don’t think it matters to enable virtual mode, but I don’t know what virtual mode in your case is, so not sure. you can read more here:


I started up Chrome, turned on the Rock-on service (I have it turned of since plex is not working anyway), and reloaded.

Then took this screenshot:

Nothing has changed. The machine has been restarted to have some drives replaced, Nothing else has changed.

If we cant fix this, I will finish building the BTRFS pool on the disks, and then reinstall and import the pool. That should reset things to zero.

But I would rather know what went wrong :slight_smile:

Re-installing is to Windows-ish, and I allways try to fix errors rather than reinstall. You learn more that way…

The BIOS has an option for:

I guess I will enable it. It doesn’t seem to hurt, and the recommended default is enabled.

Absolutely. There’s no need to re-install…yet :slight_smile: My motivation here is to understand the buggy behavior better and improve the code as needed. I do have a simple fix for you, but we are both on the same page to debug it a bit more. Could you please send me the log files in /opt/rockstor/var/log directory?

You may know this already, but you can zip the files with this command: tar czf log.tgz /opt/rockstor/var/log.

I have sent the log file to the support email adress.

Thanks @KarstenV for the logs. I am glad we solved the problem, thanks for playing. Let me summarize the issue.

The rockstor service has a child service called ztask-manager which handles asynchronous jobs. for example, long running tasks like Rock-on installations etc… including starting and stopping. It is pretty fault tolerant and retries failed tasks. When @KarstenV turned off Plex and immediately the Rock-on service, the plex job failed because it cannot be turned off without Rock-on service. The ztask-manager tried a few times and gave up. And the UI kept spinning because the Plex Rock-on is still in “pending_stop” state. ztask-manager will only try again if it’s restarted. So the solution was to start the Rock-on service and then restart rockstor from the terminal (systemctl restart rockstor) which restarts ztask-manager, which then tries to stop Plex again and it succeeds this time because Rock-on service is indeed running and can process the stop request.

This is not a major issue, but we can make the ztask-manager a bit more robust. Here’s the issue for it.


I would like to thank @Suman for the help.

This was to some extent a “self inflicted injury” made by me being to impatient. But it is something other peoble are going to be also, if and when Rockstor gets a large user base.

So I think it would be prudent to make ztask-manager more robust, so it can handle impatient amateurs like me :slight_smile: