Plex Media Server

Hi All,
Just recently joined onto Rockstor and have installed the Plex Media Server Rock on, however it looks as if the current Docker image is for a client release of Plex rather than the media server as it continally reports it’s failing to find the media server. Have tried both a fresh reinstall of the plex docker however it still seems to be an issue.

Has anyone else come across this?

Image Id for the Plex docker is 8dc744e201as

Rockon points to this image:

and in the description it states that this is a media server… Do you have another plex server installation in your network? See this link for similar trouble: Plexpass and problems?

Hi Bug11,
thanks for the response, yeah I read that article earlier however this is the only plex server I have currenlty,

did you remember to write latest or plexpass when installing? Withiout that it will not install correctly. All with small letters.

Please try that, and it that fails, then we investigate

I entered in “latest” with uuid and Gid for 1001 with a plex user name

hmmm… Double check that you use port 32400 on first connection. And perhaps use uid and gid =1000. That is the uid and gid im using, but it should work with others as well. If not, ill send you a link with a new JSON, see the other thread for henfri’s comments of problemsolving. You are not alone with your problem. We just dont know why it works for some, and not for others

Just back in the flat there, so can confirm the port is 32400 and both the uid and gud are 1000, (just uninstalled/reinstalled it there and reset the access rights to the folders) still the same reacting as a client to a plex server rather than a host application (which is why I suspect it’s to do with the current docker image)

Ill look into this tonight.

EDIT: i have done a full retest (deleted docker files and config folder, reloaded rockon list to have latest JSON and reinstall), and I cant reproduce the error.

This could be caused by a lot,i.e. firewalls, routing tables or a bug in the Docker bridge itself. and I dont have the technical skills to work that one out.

Does any other Rock-ons work as intended?

I’m pretty new to Docker containers myself, I checked my firewall settings on the router, looking at the forums with plex it shouldn’t need a portforward though I had set a few up for testing still no joy. Trying sickbeard at the moment however it seems to be having an issue using the onboard storage which interestingly enough looking again at the docker image shell access, it detects a space of 62G used and 4.1t available, which suggests that the rockstor config settings for TV and Downloads isn’t saving to the docker config file (again pretty new to the whole docker side of things so could be going down the wrong wabbit hole)

ok interesting, just manually pullted the docker image via cli and built it with the following setup:
[root@homenas tmp]# docker create \

-e VERSION=latest
-e PUID=1000 -e PGID=1000
-v /mnt2/plex-transcoding:/transcode
-v /mnt2/plex-config:/config
-v /mnt2/plex-data:/data

and it seems to of created the server no problems… so the question is is there an issue with the Rock-on scripts which is preventing the dockerimages to be created successfully

1 Like

This option is the only thing not part of the JSON script. Instead we use the port mapping, which you can read about on the bottom of the linuxserver/plex page. Appart for that, the script is just the same as the one you have manually used. Which leaves me even more curious of what is happening.

Im glad it worked out to start Plex, however this is not how it is supposed to be, from a user perspective.

1 Like

@karimicus first and a little late: Welcome to the Rockstor community. Just wanted to link back to a post I just made in another similar threat where I’m pretty sure I replicated your original findings linked forum post. Also used plex and 1001 and latest.

Thanks for helping to look into this one, I’m afraid I can’t contribute much else just for a bit but it looks like the problem is narrowing down a tad and is already in hand by the looks of it. @bug11 thanks for your efforts on this one; upon a resolution I’ll update my doc pull request against the plex howto.

@bug11 from the plex link we do have:
" --net=host - Shares host networking with container, required."
"Special note - If you’d like to run Plex without requiring --net=host then you will need the following ports in your docker create command:

-p 32400:32400
-p 32400:32400/udp
-p 32469:32469
-p 32469:32469/udp
-p 5353:5353/udp
-p 1900:1900/udp

So maybe we are just missing the 5353 port mapping.

thanks @phillxnet :slight_smile:

just been doing a quick experiment, again running docker through the command line, so setting up the port forwarding interesting enough when setting up with -p 5353:5353/udp \ it does throw up an error:

Cannot start container ples: failed to create endpoint ples on network bridge: Error starting userland proxy: listen udp bind: address already in use

it would be interesting to see whats already utilising this port on the docker/rockstor side of things

(i’ve intentionally called this one ples to seperate it out from the normal plex :slight_smile: )

@karimicus and @bug11
netstat -plunt | grep 5353
udp 0 0* 4101/avahi-daemon:

cat /etc/services | grep 5353
mdns 5353/tcp # Multicast DNS
mdns 5353/udp # Multicast DNS

And here I think is the core of the problem.

Plex wants to use the port to let everyone know it is here, I.e. “here I am, please contact me on port 32400.”

If not allowed to use port 5353, it will change to another port for this service, but that port is not automatically forwarded through the container. So we will have no contact.

I will submit a JSON with the net-host tonight, and get rid of this portmapping we are doing for Plex. And see if this solves it. If solved, then all is good, and we know where the issue is.


pullrequest #32 added. First test, works for me, and should solve port conflict.

I cross my fingers that i have created a OK pullrequest for @suman and not messed up again.

I had to use --net=host to get this to work as the other thread said. I gave up after a lot of tries, it just won’t connect to the Plex Media Server but running it straight on the CLI worked fine with --net=host

Please find not approved rockons here (my play-ground):

Here you will find the plex rockon with -net=host option. The rest are the same as in rock-ons at the moment, as they are not updated since the pull request


it seems the Plex Rock-ons has been updated recently to a newer version as there is new input required during install as also dicussed above. I’ve used the following parameters and I get always the error, that there is no Plex Server found even by being at the WebGui interface of Plex itself. Any quick help or trick you can provide?

Thank you-BR,