Plex Media Server

And here I think is the core of the problem.

Plex wants to use the port to let everyone know it is here, I.e. “here I am, please contact me on port 32400.”

If not allowed to use port 5353, it will change to another port for this service, but that port is not automatically forwarded through the container. So we will have no contact.

I will submit a JSON with the net-host tonight, and get rid of this portmapping we are doing for Plex. And see if this solves it. If solved, then all is good, and we know where the issue is.


pullrequest #32 added. First test, works for me, and should solve port conflict.

I cross my fingers that i have created a OK pullrequest for @suman and not messed up again.

I had to use --net=host to get this to work as the other thread said. I gave up after a lot of tries, it just won’t connect to the Plex Media Server but running it straight on the CLI worked fine with --net=host

Please find not approved rockons here (my play-ground):

Here you will find the plex rockon with -net=host option. The rest are the same as in rock-ons at the moment, as they are not updated since the pull request


it seems the Plex Rock-ons has been updated recently to a newer version as there is new input required during install as also dicussed above. I’ve used the following parameters and I get always the error, that there is no Plex Server found even by being at the WebGui interface of Plex itself. Any quick help or trick you can provide?

Thank you-BR,

are you using the standard one in Rock-on library?

I do think that you are, due to all ports being listed, please uninstall and use my plex, as you can find linc and installation way in this thread: Plexpass and problems? - #19 by bug11

Yes I’m using the standard Plex from the Rock-ons libaryas it worked last time before I’ve done a complete new install of Rockstor itself due to new set of HDD’s, but meanwhile this newer version seems to make problems. Has it not been enough tested before going online or is there a mistake on my side? :slight_smile:

Meanwhile I’ve found your reference post…

Not a mistake,

the official plex plugin has a port conflict and thus shuts down. so the reason for you not finding the plexserver is because it is not running. (the simple explanation, i have not been digging, it is in the reference post).

Just download and add my plex JSON, as described, and it should work as intended.

@bug11 tried to uninstall (org. plex rock-ons), created directory (opt/rockstor/rockstor-metadata), downloaded plex.json from your liink (, pushed the refresh button and installed again the plug-in. Same parameters have been asked like PUID/PGID and same error in not finding the plex server afterwards :frowning:

What could be the reason - it seems the uploaded plex.json has not been used for install isn’t it?

Thanks for any continued support!

folder is not named correctly, ill edit that other text.

correct is /rockons-metastore/ instead of metadata… Sorry about that, if using winscp its just rename folder. Im unsure of how via SSH.

@bug11 thanks again for quick reply - I’m a newbie on Rockstor, but maybe my “stupid” questions will help others :slight_smile:
by using the following link and its file I get belows error after refreshing the webGui?


are you using a windows machine and chrome browser? because using the rightclick option and save target to, does not work. It saves a whole lot of weird links. Just found out my self, Great find!

Please use the download zip option from github. or use wget directly from server, and it should work. Send me a PM if you still have trouble.

1 Like

Finally I was able to install due to other issues I had to uninstall and install again, but now there is no selection of the different shares required (config, data, db) it starts with the following screen

After being installed it shows the following…

Does anyone knows a trick to get this solved? (selecting/defining the other basic shares)


That is a GUI error, not sure why. The option to select shares is part of JSON. Please cancel install, hit refresh and try again. I know @suman is working on GUI improvements, so if you can find anything in any logs to help identify what is happening here, please submit to him. As this will help him improve on the GUI experience.

I’ve uninstalled Plex, turned off Rockons and rebooted Rockstor/NAS, switched on again Rockons - refreshed the list and installed again -> this time the different shares were asked again…luck? :slight_smile:

Another question - is there a way to remove added storage (using wrench symbol)?
I’d like to see in future maybe also a “remove storage” button if possible?

1 Like

Just a quick update. I’ve fixed up the Plex rockon profile to use host networking and also made a few changes in light of upstream Plex and docker images changes. I gave it a quick test and it’s working. Try it out!


Works great, I removed the custom docker container and then tried the rockon and it appears to have worked well.

1 Like

I just want to make sure before I try again to add storage and possibly crash Plex.

These are the settings done during install

The indicated plex-data “/data” does not contain any media…
All my media (photos, videos, music) is on “rm_share” - replacing the “/data” by the “rm_share” did not help to be able to find and add all my media to the Plex library through the webinterface.

If I would use the “add storage” button what needs to be put into the “Rock-on directory” based on aboves settings?

Sorry, it seems I got confused somehow as the most logical approach by selecting “rm_share” as the data share rulted not to see my media within Plex. THX

I ended up copying data into a new share. But if you go into plex and add a directory (plex UI) you should be able to navigate and add your share. Since you can add a new one I’d create one for the install and then just attach the new one later. It won’t destroy data.
I navigated to /data within my share from the plexui

Is that along the lines of what you were asking?strong text

@magicalyak I don’t want to duplicate data. If I try to add e.g. videos to my library within the plexUI and look up in /data…I can’t see my files independent which share I’ve selected during installation (rm_share or new plex_data share).

Question: using the wrench to add storage functionality - should be the “Rock-on directory” the path where the new share should be mounted in? e.g. mount “rm_share” content into “/data”?

Solved: I’ve added my “rm_share” and destination “/data/media” and now I have all my media mirrored into this path and accessible by plexUI :slight_smile: