Plex Setup Issues

This has been extremely frustrating and hoping someone could assist.

  1. Running a clean install of 3.8-14
  2. Followed for the setup
  3. My config
  4. Once I select “Plex UI” I am taken to a login screen where I login with my plex account, I log in.
  5. I do not see my current server but other PMS servers associated with my account.

@rockstoruser24 Hello again. I’m pretty sure that the ‘plexpass’ version entry is no longer a valid entry. I.e. from the doc you reference:-

“VERSION ie latest for latest version or a specific version if desired.”

I seem to remember that ‘plexpass’ used to be an option here but was then dropped in favour of the client just adapting it’s version according to the user credentials entered. So I would try turning this Plex Rock-on off, uninstalling it, then re-installing but use ‘latest’ in place of ‘plexpass’.

Let us know how you get on.

thanks for the quick response but still didn’t fix it :frowning:

@rockstoruser24 OK, that’s a shame. Hopefully someone can chip in with another suggestion on this one.

I installed Plex yesterday with “latest” for Version. This went fine. Altough it was a bit awkward to configure the share with my media later, but it worked and plex runs like it should.

Maybe you uninstall the complete Plex Rock-On and install it again with latest as Version.

I had similar issues where I could see my existing Plex servers, but not one I had just installed as a Rockon. Logging in on port 32400 (from clicking the “Plex UI” button, wouldn’t allow me to sign directly into the plex server. I ended up doing a port forward over ssh to allow me to connect to the instance of Plex which I was then able to go into the server settings and troubleshoot remote access and NAT issues. You can give it a shot with PuTTY by connecting over ssh to your rockstor appliance. Once your connection is established open the connection settings and go to Connection > SSH > Tunnels and try something like

Source port: 9999

After you apply that you should be able to go to (or https, can’t remember) on your computer running putty and enter the server configuration there. This helped me to track down issues with my firewall and NAT.

@williams.tlr wow that worked! Now I need to figure out what is going on here

@williams.tlr You sir, are a god amongst men.

I noticed on the Plex ‘where is my server’ page, it stated to access plex via localhost, and I couldn’t fathom how to do that via docker - did not even think of SSH tunneling to it.

I’ve been silently fighting this war not wanting to bring it up on rockstor forums as I know it’s a Plex issue and not a rockstor issue :expressionless:

I know the topic is old, and I’m probably being annoying by bumping it, but after an age of googling, I thought I’d bring it to light in case anybody else has been experiencing this pain.

@Haioken Thanks for waking up this thread:
In relation to the following:

we do have a rockstor-doc repository issue open that I think is related:

When accessing the Plex Web UI via it’s “Plex UI” Button on the Rock-ons page it can under some circumstances fail to show the UI and only present a Plex User Sign In / Sign Up page when there exists a functional Plex server UI. The caveat being a requirement to use the Rockstor machine’s IP: …

One can, more simply I think than setting up a port forwared, simply substitute the Rockstor ip for it’s hostname after the ‘Plex UI’ button generated URL. Bit of a pain this one but there we go. Not entirely sure if this is the same problem but it’s one I’ve come across and hence the issue’s creation.

Always worth looking to outstanding issues in either rockstor-core, rockstor-doc, or rockstor-iso repos.

Hope that helps.

I had actually tried this, accessing plex on brought me to a plex login page, and the stuck on ‘looking for servers’ with no result.
The only way I was able to do it was tunneling to access the server as localhost. (, at which point I was greeted with the server setup screen.
Since that was completed, and the server registered with, the service has been working flawlessly.

1 Like