Plexpass and problems?

Please find not approved rockons here (my play-ground):

Here you will find the plex rockon with -net=host option. The rest are the same as in rock-ons at the moment, as they are not updated since the pull request

@bug11 Do I just replace these files with whatever is on rockstor? What directory should I be looking for on rockstor?

See usermanual, but in short steps: create folder rockons-metastore under /opt/rockstor/

Then download and save JSON files as needed, press refresh i webinterface, and you will see rockons in available interface.

Most have Tronder88 in description, showing they are mine, and you will also know they are loaded as intended

EDIT: corrected filelocation from metadata to metastore

Bug11, what about updates for the plex json, will they come as usual or do i need to delete te json file and folder to have them?

slightly unsure of what you are thinking about. To update plex and others, it is simply just restart them (turn off then back on again). That is how they are built. Or you can use the update function on some images, read on the hub.docker on how the update is suggested. If it says restart to autoupdate, that is how the update is performed. Plex is that way. Sonarr has a autoupdate built in which works

1 Like

@bug11, which manual are you referring I look at? I downloaded the plex json file in /opt/rockstor/rockons-metadata but I did not see the plex rockon with a description containing tronder88

The manual i was referring to is the readme here:
it explains how to install JSON files manually.

Did you press the update button on the rock-ons page? it will load all JSONs from the rockons-metadata folder.

Ah, your earlier post said rockons-metadata but the readme had rockons-metastore :slight_smile:
I changed the folder name and now see it :slight_smile:

Plex worked great btw, and I tried adding your sonarr as well. However, when I select update from the rock-ons I get this error

“Errors occurred while processing updates for following Rock-ons. Plex: Cannot add/remove volume definitions of the container( as it belongs to an installed Rock-on(Plex). Uninstall it first and try again.”

Not sure why it is referring to plex when I am trying to get it to see sonarr?

You cannot add/remove folder mappings on a running container. And from your error, it looks like you have tried to do some edit on the plex, which is not yet saved. Easy solution is to uninstall plex and install again (you will then get the latest version). Install other images in between uninstall and install. Plex reinstall is a quick one since database and config are located in separate folder.

1 Like

@bug11 What I did was uninstalled plex, reinstalled, shut down plex, and then added a storage path through the GUI to point to the share with the videos. Lastly, I turned on plex and when I do an update I receive that error.

I also tried doing an update before adding the storage path and I do not receive the error. I understand adding the storage path is why I receive the error. However, I am not sure I understand based on your reply how else I can add a storage path without receiving the error upon updates.

1 Like

@rockstoruser24 I’m facing exactly the same problems…

In addition I’ve to say…I’ve added storage and it worked, but after a restart of the server it doesn’t work any longer.
Turn-off and on again it does not help :frowning:

-> no more access to my added storage and the error message when hitting the update button

I can also add storage… Just have to remeber to add it like this “/ekstra-folder”.

Now I have not tested turning server off and on, just the rock-ons service. In addition I run 12-11 version and my own rock-on from

Nevertheless this should not be an issue, and since two of you have trouble, I do ask that you copy part of log and add in this thread so that someone can have a look. Are you running 12-11 edition? if not, could it be possible to upgrade? as rock-ons are built on top of docker, and we do not know which docker version you are running.

Í’m running 3.8-12 stable updates, nothing done manually…so no clue about any additional versioning :slight_smile:

under /opt/rockstor/var/log/ there are a couple of files, which ones you’d like to see?

[root@rockstor log]# ls
gunicorn.log supervisord.log
rockstor.log supervisord_nginx_stderr.log
supervisord_data-collector_stderr.log supervisord_nginx_stdout.log
supervisord_data-collector_stdout.log supervisord_ztask-daemon_stderr.log
supervisord_gunicorn_stderr.log supervisord_ztask-daemon_stdout.log
supervisord_gunicorn_stdout.log ztask.log

Rockstor log usually has some information of what has happened with docker.

As for stables/testing, I do suggest to update to testing for the time beeing if possible, as Rockstor has moved to 4.4.5 LTS kernel in the testing channels, and also fixed a lot of bugs for Rock-ons. And also in the kernel: quite a lot of improvements for BTRFS in the 4.4.

I plan my self to go to stable when we reach version 13 or 14. depending on kernel version as a lot of stability improvements for btrfs are happening in 4.6 and 4.7 (hot-swap, hot-spare, and striping).

is there any way to get the content of the rockstor.log file posted in a good way ~2300lines?
upload is only for pics…not for .log files

@glenngould I just upload to Google Drive and share it with a link

1 Like

@glenngould When I upgraded to the 12-11 version and did a reboot, I am not able to add storage and perform an update. The latest non-stable version seems to fix that bug ironically enough :slight_smile:

Below the link to my log-file

I’ll wait for any feedback before I upgrade to the test environment - thank you.

I couldn’t hold myself back and went on with the update to 3.8-12.11 and installed again Plex after a reboot.
I’ve experienced the same on my side, that the update error disappeared, but there seems to be still a problem with “manually added storage” which worked before once. For now I can’t access all my media…

Does anyone know which config file does take care of those additional storage paths and where it is located?
Possibly after reviewing and/or removing them manually will help to get this sorted?

Even when I delete the “plex-config” share (incl its containing files) while Plex is uninstalled, this dead linked manually added storage stays??

I’ve made already a remark that this simple feature such as a “remove button” for additional added storage would be very helpful I guess…