Plexpass and problems?

Philip, thanks for responding. I have tried the new installation ( i even reinstalled the whole Rockstor) but still the same. I am perfeclty able to enter plex, but the Rockstor server doesnt show up. I kan understand why since i do not get the setupscreen for the server when logging in, just straight into the Plex GUI. I have tried everything I can think of, but no luck. The service says it is up and running (current status: Started)

The computer i am using to access Rockstor is the old one i use to have Plex on. Might this be the reason in some way?

My $0.02

That is an issue after a quick look. Installing plex on rockstor with another plex server available and port forwarded to internet, then it will not be possible to connect to new rockstor server.

Looks like this will sort things out after quick test.

-1) Uninstall plex server from other computer on the network where the same login is used.
-2) have port forward in router preconfigured to point to server

Writing this here, as this might become an issue for others when migrating to Rockstor.
Cause of this? I have no idea. But it is worth a try

see this link for others with the same issue:

1 Like

Bug11, i tried your suggestion, no luck. I think im just damned :confused:

Not sure how to attack this now really… Made a temporary “fix” by managing to add my server disks to plex on my computer. At least its good for something now…

@henfri - do you have any ideas? On my comp it works great, on others they have trouble…I see on github you have done some of the coding. I do suggest for most using gid and uid =1000. However linux io do suggest using the net-host option which was removed, and i now start to wonder if we include that it will work. That said, one will loose control of portmapping though the JSON. Any thoughts?

@bug11 Thanks for looking into this one, but I’d just like to throw in that I don’t think running the plex server as UID GID 1000 is advisable on Rockstor as that is the admin user and I think a little separation there is a good thing, plus it encourages people to create additional users to split things up and be more mindful of that side of things. What do you think. In the revised doc I suggested a plex user and to look up their UID GID and set all plex associated shares to plex.plex 750 so only the plex user can write and no ‘others’ access. This seemed like a safe side suggestion.

I set about updating the docs the other day and so quickly ran through a plex install and found the same issue as some others have had, ie when visiting the PlexUI I was presented with a login sign up and no other options. Signed in with plex account anyway and it appeared not to be able to find itself even. Ran out of time on that one and had made improvements anyway so submitted changes as was and put it down to running in a KVM (ease of replication for the docs).

The proposed and not yet pushed to web site plex howto update where I reproduced the suspect behaviour is available at this GitHub view link. But note that the last image was left over from a previous image install as for me on this install it would just display a “Looking for servers…” message as follows (screengrab):

The doc details the steps I took, and would generally recommend, and I used as detailed the latest version entry although I logged in using a plexpass account on first Plex WebUI visit. I had initially just assumed this was a new forced login thing from the newer server version but it seems not. @kaiHai it looks like my experience was a little different from yours as I did get a login when first visiting the plex WebUI via the Rock-on button. My install for the docs was done via VMM KVM on Fedora 23.

I would say my experience was more akin to @karimicus over at the [Plex Media Server] (Plex Media Server) thread. I will link back here later but already involved in this thread so reporting here. I’m afraid I don’t quite have the time to look further into this at the moment hence reporting what I can here for now. @bug11, seemed network related to me also, ie can’t find itself.

@bug11 Looks like @karimicus over at the other thread has made some progress on this one, along the lines we suspected also ie network. OK just notices you are on it, Thanks.

For some reason I don understand, the port per port option we are using are not working as intended.

Looking at: under special note: we can skip the nethost option, which worked for @karimicus . And it works on my installation, which makes this even more difficult to solve.

I do think that, from a user perspective, I will update the plex JSON with nethost option, and e-mail this to @suman. I cant figure how to use github, it messes with pullrequests eventhough I follow the readme step by step. I use github for win10, maybe that is the issue for me here.

Will fix this, this evening, and hope our users will have their problems sorted.

1 Like

@bug11 Re the git issue, are you making a new branch (from updated master) first then doing your changes in that branch only and only changes related to the specific issue. I noticed that @suman has recently improved the instructions on git and the rockon-registry repo. Maybe that will help, they are in the I think the Windows git clients do tend to lag but they should be good for this kind of thing.

Then once the issue is resolved / pull request merged you can delete that branch and then won’t accidentally re-use it for another issue.

1 Like


I think we experienced the excact same thing. The only difference is that i had the plex password stored in my browser :stuck_out_tongue: I will await the new version and try again.

Thanks for all your help guys!


Well i be dammned, but the latest release from bug11 fixed my problem at the very least :smiley:

Great work Bug11 and others.

THANK YOU! :smiley:

1 Like

I have the same issue, which of bug11’s suggestions ended up working?

Hi, what fixed my one was that i know him and was able to test the new json file he made:) so pure luck for once:) I would believe he has sent this one in for all to use, but if not he might be able to send to you as well if ok for others here. Not sure how this normally works:/ i recon he will respond by the day.
You will be up in to time, no worries:)

Please find not approved rockons here (my play-ground):

Here you will find the plex rockon with -net=host option. The rest are the same as in rock-ons at the moment, as they are not updated since the pull request

@bug11 Do I just replace these files with whatever is on rockstor? What directory should I be looking for on rockstor?

See usermanual, but in short steps: create folder rockons-metastore under /opt/rockstor/

Then download and save JSON files as needed, press refresh i webinterface, and you will see rockons in available interface.

Most have Tronder88 in description, showing they are mine, and you will also know they are loaded as intended

EDIT: corrected filelocation from metadata to metastore

Bug11, what about updates for the plex json, will they come as usual or do i need to delete te json file and folder to have them?

slightly unsure of what you are thinking about. To update plex and others, it is simply just restart them (turn off then back on again). That is how they are built. Or you can use the update function on some images, read on the hub.docker on how the update is suggested. If it says restart to autoupdate, that is how the update is performed. Plex is that way. Sonarr has a autoupdate built in which works

1 Like

@bug11, which manual are you referring I look at? I downloaded the plex json file in /opt/rockstor/rockons-metadata but I did not see the plex rockon with a description containing tronder88

The manual i was referring to is the readme here:
it explains how to install JSON files manually.

Did you press the update button on the rock-ons page? it will load all JSONs from the rockons-metadata folder.

Ah, your earlier post said rockons-metadata but the readme had rockons-metastore :slight_smile:
I changed the folder name and now see it :slight_smile: