Previous Versions - Wrong Times [Solved]

Hey guys, I have created a new share and set up a new snapshot task in the task scheduler as well as enabling the shadow copies, everything is working fine no worries a part from the incorrect times of the previous versions on the samba share.

Here is the snapshots on RockStor with the correct times.

This is the incorrect times on the previous versions

I made sure my ntp server is set correctly as it shows the right times in the snapshots on RockStor webui. I have tried to restart the smb service, rebooting RockStor but no luck. It seems am missing something but I can’t figure it out.

Thanks Folks

Hi @Mahmoud87,
that’s a really strange behaviour (previously had some tests on shadow copies without problems).

Are Rockstor server and your client on same time zone?? ( looking to your snapshots it seems ok )

Maybe we can move from local time snapshots/shadow copies to utc timings (there’s an open issue on it)

Anyone else having some problem??


1 Like

Hey @Flyer, yes mate they are on the same time zone, am not really sure how to change the time zone since I don’t have an option to change it after the installation!!!

One minute test:

storage -> samba -> edit your shadow copies share and add this on custom configuration box:

shadow:localtime = yes

While enabling shadow copies current snapshot format is well defined with shadow:format, so win machines should understand it except for local time / utc-gtm time

Let us know if this solves it :slight_smile:


1 Like

Cheers mate for the super quick replay :smiley: , will test it and will let you know thanks again.

Seriously mate you awesome all fixed now times are correct

Was there any reason for the time to go wonky like that?? If there is no answer its cool am glad it was simple and it worked :smiley:

1 Like

Hi @Mahmoud87 thanks for your testing!, going to open asap a pull request on github closing issue by fkurth!! :slight_smile: (this test confirms we can just add samba local time flag and avoid rewriting snapshots code for utc :wink: )


Terrific mate and hopefully will get fixed in the next builds. Thanks again @Flyer :+1: