Problems creating bootable installation USB flash drive on a Mac

Using a late 2011 MacBookPro runing latest version of OS X El Capitan (10.11.2)
NAS is a new 45 Drives Q30:
SuperMicro X10DRL mobo
Dual E5 2620 2.4GHz Xeon
30 x 4TB WD Re 7200 drives
3 x dual port Intel X540T2BLK Intel X540 DA2 10GBe NICs

The Q30 will be used as shared storage by an ultra Hi-Def 2K/4K/6K film production company for online editing and post-production

I’ve tried the Quick Start method “dd if=Rockstor-3.8-10.iso of=/dev/disk2” on USB sticks formatted as Apple HFS+ and exFAT. It takes good while, but data gets written and I end up with flash drives that look like this

But, when I insert it into our new Q30 NAS, I get nothing - no booting

I also tried converting the Rockstor .iso to .img via “hdiutil convert -format UDRW -o ~/path/to/Rockstor.img ~/path/to/Rockstor-3.8-10.iso”, then doing the same “dd…”

I end up with the same looking contents of the flash drive as creating from the .iso

I suppose I should just find a Linux or Windows machine and use one of the apps to do it(this is a Mac-only company).
But, is there something obvious I’m doing wrong?

@VictorR I would hazard a guess that the problem is not with the creation of the usb boot stick, given there is little that can go wrong with the dd method as it pretty much “direct data” images over the top of whatever is on the usb stick, but with the settings in the bios of the 45 Drives machine to boot the usb stick first. Try booting another usb key just to narrow down the problem ie an Ubuntu 14.04 usb key or a CentOS 7.2 key. Note that no conversion of the downloaded image should be necessary.

Let us know how you get on.

I’m pretty sure 45 Drives does have people that visit the forum that may well be able to help or correct me on this matter. I believe @bkelly is one given a recently active thread on the forum.

Hi Phil, thanks for the response
the Q30 is set to boot from USB as it currently does from a FreeNAS 9.3.1 thumb drive.

My only guess at what may possibly be going wrong is that if I do a “diskutil list” from terminal on my Mac, the formatted USB drive appears as disk2. The formatted HFS or exFAT section appears as disk2s2
I have been dd’ing to the entire USB stick at disk2. Do you think I should be using disk2s2? (this doesn’t make sense as dd overwrites the entire volume)

(USB dumb drive comes formatted FAT32. I tried it that way with no luck. so figured that maybe HFS+ or exFAT might work}

BTW, Brian Kelly is actually the person who encouraged me to try Rockstor. He ran a TeamViewer web demo installation and configuration(3x10 drive RAID 6) for me on a similar Q30 and I was really impressed with the clean GUI, intuitive setup, and ultimately read/write speeds

I’ve ordered a installation thumb drive from Rockstor, but need to get something up and running for testing now. This thing is supposed to start getting use Friday or Saturday - with nightly backups, just in case

@VictorR Fancy that re @bkelly . OK let me have a little dabble here for a bit and try and reproduce your issue then I may be able to help further. Thanks for the extra info and my understanding is that any existing format is irrelevant as the image overwrites all that previously existed on the usb stick, as you point out, including the partition table. So Yes I think you are doing the right thing to image to the whole disk/usb stick rather than to a partition on it. Give me a little while and I’ll have a look again at the procedure.

Thanks Phil.

I’m working in a Mac-exclusive environment right now, so there are not other options readily available.
But, I am going to stop by a friends house and create another USB off his Windows machine using Rawrite32 before heading to the office.

@VictorR Make sure the md5 of the image you have is correct also, ie in a terminal on OSX in the directory of the iso file:-

md5 Rockstor-3.8-10.iso

Should result in:-

MD5 (Rockstor-3.8-10.iso) = 12c6f7fcf61c211e1b9b4bc6be78f2c1

as you may just have a corrupt image.

Seems to check out

@VictorR Cheers, at least we know the downloaded image is OK now.

I’ve just verified the method on a 2007 MacBook Pro (A1229) running OSX 10.11.1 .

In my case the usb key was a ScanDisk Ultra USB 3.0 and I created it from the Rockstor iso using the dd command in the terminal via:-

sudo dd if=Rockstor-3.8-10.iso of=/dev/disk1

This took a whopping 566 seconds (old usb ports) and in my case there was only one other drive on the system so my usb key showed up as disk1, like you I established this via the:-

diskutil list

command which produced the following output:-

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *250.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS OSX-system-drive        249.2 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            Rockstor 3 x86_6       *15.6 GB    disk1

Note the above diskutil list command output was produced after running the dd command and then waiting a while and making sure the usb key was not automounted and then removing it, trying it in another generic pc for boot function and then returning it to the mac so I could show the diskutil list output in this post.

The resulting usb stick was able to boot OK on a generic PC I have here.

Sorry that’s not much help I’m afraid. I can only suggest that you have a faulty USB device or USB port.

Let us know how you get on with this. At least you know it works here with the above method which is exactly what you did originally.

Thanks Phil, it could be an issue with my MacBookPro, as you say
I wil try on another Mac Pro in the office and also a Windows machine

One way or another, I will have Rockstor running today!!!

@VictorR Yes see how you get on with different USB sticks as well as I think that is the next most likely candidate.
Good luck.

1 Like

Well, good news…and bad news…and other bad news

The good is that there was nothing wrong with the installation USB thumb drives
The bad is that the VGA port on the motherboard is faulty. So, it wasn’t passing a signal unless held at just the right angle via ziptie

And, the other bad news is…

After the initial Rockstor install splash screen, there is an early [5.924261 i8042: No controller found] error. Which, searching the web, seems to be a problem with the kernel and 8042 chip related to USB keyboard/mouse.

Also, during the scrolling install messages, there is something about an issue with /dev/sdc being read only.

Then at exactly 8 minutes into the install there is a quick “An unknown error has occurred. This program has encountered an unknown error. You can report the bug below or quit the program” flash screen. But, it disappears before I can click report or get more details. The installation hangs on a black screen with the mouse cursor arrow. I can move the cursor, but nothing else. I let it go for another 5+ minutes, but nothing happened after that. . I ran the installation 4 different times with the same result. (should I have let it go longer?)

I have a video of the entire 8+ min install that I made with my iPhone. The file is 1.25GB, so I’d have to FTP it up to my website and send you a link, if you need to see it.

To confirm that there isn’t another hardware problem, I rebooted the Q30 with the FreeNAS USB thumb drive and it worked perfectly. I can create volumes( 3 x 10 vdev in RAIDZ2), shares, etc. We were able to write 14TB of files to it and read them.

@VictorR Well as you say this is progress but not as much of it as we had hoped obviously. The installer used by Rockstor is simply the default CentOS 7.1 installer pre-configured via their kickstart system. On the plus side it’s nice and friendly being all graphical via X but on the down side this does open it up to more potential incompatibilities.

The 8042 message is a red herring and can be ignored so that’s one down especially since you don’t report keyboard issues.

/dev/sdc read only sorry nothing springs to mind on that one yet.

What I suspect is that X the graphical subsystem linux tends to use is crashing half way through the installer. There is a strong likely hood that this affects all CentOS installs on identical hardware and we just have to find a way around it.

First could you try the “Test this media & install Rockstor” option just so we can rule out a defective USB stick; they more common than is usually thought and it’s a pretty quick and easy test. To get to this you use the cursor keys on the very first screen that appears on booting the USB stick and then select via Enter key.

Let us know how this goes, we only need to see if the initial test which is run in text mode passes as the rest of it is exactly the same as what you have already done so no need to put yourself through that again until we have confirmed that the text mode install media test has passed without error.

If the media test passes it goes directly into the standard graphical installer that you are now overly familiar with. If it fails it refuses to go on with a message to this effect.

@VictorR By way of a test I have purposefully corrupted an install iso file by a single byte and then performed the “Test this media & install Rockstor” option with the following result (screen grab):-

Note the white space in the above is an artifact of the kvm display and not relevant.
Note the “Refusing to continue”. Just wanted to confirm the behaviour as I was unsure when I did my previous post.

Attempting an install with this same corrupted image gives the following result (screen grab):-

@VictorR If in fact your media test passes then I would say the next thing to try is the “Install Rockstor in basic graphics mode” option which is found inside the “Troubleshooting” menu ie (screen grab):-

And then you should see the following options (screen grab):-

N.B. the “Run a memory test” is also a good option but will take quite a while as it is very thorough and at least 2 full passes is generally recommended. Ensure you system has good cooling if you chose to run this as it can be very demanding on parts of the hardware. Remember that this test never ends so you will need to ESC out of it when you are reassured that your memory is good. I know that you have tested the hardware with FreeNAS already but given that Linux (Rockstor - CentOS) and NanoBSD (FreeNAS) are very different systems it could very well show itself in one system very differently than in another. Just noting this menu items function in case it comes to that.

Hey @phillxnet, thanks for your supper thoroughness here. I just want to add that I have a q30 and I installed rockstor on it countless times including the latest and yet to face any of these issues.

I have seen the unknown error in the installer while on other hardware, but it always worked on a repeat attempt. To rule out the iso corruption you could install it on different hardware or using virtual box on Mac.

Luckily, I ran the “Test This Media” option last night and made of video of that part of the test. It got a “Pass”
Here’s a screen capture

The difference between your “An unknown Error has occurred” message and mine is that with ours, there is no background Rockstor screen at any point after the initial splash screen. It’s either all grey, or black, I can’t remember

BTW, I do get the same white square at the media check as you do - without a KVM. We are using a VGA cable direct to monitor.

It does concerns me that Suman and Brett Kelly at 45 Drives have both done multiple Rockstor installs with likely the exact same hardware in their Q30’s (Supermicro X10DRL mobo, WD Re drives, Highpoint Rocket 750 HBA(?), Intel 10GBe NIC cards, and same RAM manufacturer - we have 256GB) without problems. We already replaced a bad SATA cable, and there is the VGA port issue, and whatever is causing this - now that we know the install media is good.

Unfortunately, I don’t think I am going to get a chance to run the memory test. These guys want to put the(a) Q30 into production by Friday/Saturday (I know, a really, really, bad idea at this point). But, it has been 3 weeks since they received the NAS and they have a reality TV show they need to start editing on right away. I’ve requested a replacement Q30 from the 45 Drives team

But, in them meantime, there guys want to start testing out real world bandwidth around the office on their new 10GBe network and the NAS. So, it is back on FreeNAS and we left at midnight while a test 14TB of mixed 2K/4k video was being transferred to it.

Since we would likely be transferring the HDD’s, NIC cards, and RAM over to the replacement Q30, I will try to make the case to them that it would be important to test the RAM before doing so. Not sure how much luck I will have with that…I’ll let you know

I just thought of something that may make it possible for me to run the RAM test!

Even with the Rockstor install failing multiple times at the same point, when we switched back to FreeNAS, it hadn’t overwritten the 3 x 10 vdev RAID Z2 volume or shares I had created in FreeNAS. The Rockstor install hadn’t gotten to the point of touching the HDD’s. It was all, obviously in RAM and maybe the dual SSD drives…makes since because I hadn’t created any RAID config.

Do ou think I could shut down, switch to the Rockstor USB, and run the RAM test without corrupting the video files we transferred last night in the RAID volume? If so, I can probably do that tonight after everyone leaves.

The upside would be that if we somehow get Rockstor installed as a tester and they see the better bandwidth that Brett got over FreeNAS, they would have no problem going with Rockstor when the replacement Q30 arrives.

The suggestion I am going to give has nothing to do with RAM, but also worth trying, It’s possible that the installer is failing while probing the hard drives. You could wipe the hard drives manually either before install or right at the start of install from shell in a different tty while the graphical installer is loading or waiting for your input. wipefs command is helpful here.

I left you a PM with my number, give me a call if you like. I can assist you better, perhaps.

@VictorR Thanks for the update. Yes my unknown error demo was just to prove that a corrupt install media could lead to such an error. It may not take that long to test the memory and with any system zfs or btrfs there is a possibility of corruption if it’s bad. If the memory is ECC then that would reduce the chance of corruption. But then it could be a memory controller that is flaky and not the actual memory. I still favour the idea that we have either an X incompatibility, which may be helped by the basic graphics mode install or a flaky video controller or video memory (if seperate).

Thanks for the pointer white square background in the test media, just haven’t tested in real machine on that page much. Good to know.

Oh well looks like you may be out of time so all the best and I hope the new system proves to be less problematic. Do let us know how it goes as it’s obviously been quite an adventure, if all a bit last minute. Sorry I couldn’t help you more but looks like you may be on the right track diagnostically anyway.

OK as I type this I see you have responded on the memory test issue.

It is entirely possible to boot the Rockstor Install stick and select the memory test and it will touch nothing on the machine hdd / ssd wise as it is all run as you say in memory. It’s just a live image and won’t touch anything until you get to the install. The memory test is like the USB being a dual boot system. One to run the installer / recovery and one to run the memory test. Hope that answers your question. Note though that if the system is faulty / about to fail then stressing it will bring this on. However if it’s healthy with regard to the stressed parts then all should be well, plus it’s best it fails during memory test rather than in production anyway.

Hope that helps and whatever happens do let us know. I see @suman has also responded while I was typing, my what a busy thread this is. Good luck.

Then, I am definitely going to run the memory test late tonight, As you say, if something is faulty, I’d rather have it fail now than in production.

While an X incompatibility may be the issue, we still have the case that Brett (and possibly Suman) are running the exact same hardware/drivers and version of Rockstor. So, I’d think that would have shown up in a few of their installs. But, your video controller/memory suggestion could be dead-on. Especially since there is already an issue with the motherboard. We may have just gotten a faulty one. Not major crash(yet), but buggy. It happens

I will update you guys late tonight (Pacific Time) on the results of the memory test and we can work from there. I would much rather run Rockstor on this than FreeNAS as the GUI is much cleaner and more intuitive. These guys need to be able to maintain the Q30 after I leave and Rockstor will make that much easier…along with the better bandwidth