Relation "storageadmin_pincard" does not exist (following upgrade from 3.8 to 3.9.1-2)

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

I’ve upgraded my Rockstor instance from v.3.8.x (3.8.4 to my memory) to v.3.9.1-2. It seems that the DB was partially corrupted (missing tables?) during the migration.

Detailed step by step instructions to reproduce the problem

In upgraded Rockstor instance, open admin console, click on System > Identity > Users. The error message will appear.

Web-UI screenshot

Error Traceback provided on the Web-UI

[ Traceback (most recent call last): File "/opt/rockstor/src/rockstor/rest_framework_custom/", line 41, in _handle_exception yield File "/opt/rockstor/src/rockstor/storageadmin/views/", line 106, in get_queryset return combined_users() File "/opt/rockstor/src/rockstor/storageadmin/views/", line 61, in combined_users uo.pincard_allowed, uo.has_pincard = pincard_states(uo) File "/opt/rockstor/src/rockstor/system/", line 146, in pincard_states pincard_present = has_pincard(user) File "/opt/rockstor/src/rockstor/system/", line 129, in has_pincard pins = Pincard.objects.filter(user=int(uid_field)).count() File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/", line 318, in count return self.query.get_count(using=self.db) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/sql/", line 466, in get_count number = obj.get_aggregation(using, ['__count'])['__count'] File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/sql/", line 447, in get_aggregation result = compiler.execute_sql(SINGLE) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/sql/", line 840, in execute_sql cursor.execute(sql, params) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/backends/", line 64, in execute return self.cursor.execute(sql, params) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/", line 98, in __exit__ six.reraise(dj_exc_type, dj_exc_value, traceback) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/backends/", line 64, in execute return self.cursor.execute(sql, params) ProgrammingError: relation "storageadmin_pincard" does not exist LINE 1: SELECT COUNT(*) AS "__count" FROM "storageadmin_pincard" WHE... ^

@Igor_BAREEV Welcome to the Rockstor community.

That’s a pretty hefty upgrade and is not a supported upgrade path on testing. Essentially prior to 3.8.15 to 3.8.16 or later is not supported as a ‘stop off at 3.8.15 was require’, stable subscribers were sent the relevant instructions and should have been OK if auto updates were in place. Hopefully the following forum thread can help you get up and running again.

Bit of a pain but we transitioned from south to built in django database migration which was a non trivial change.

See how you get on and be patient as the migration can take a few minute in some instances. You may very well be better advise to do a re-install and import your pool/shares, ie Reinstalling Rockstor Just be sure to disconnect all data drives prior to attempting a re-install as it’s easy to pick the wrong disk. Also any data stored on the system disk will be lost. Best back-up all stuff prior to changing anything really.

Hope that helps.

Thanks, I’ll definitely consider to use this migration scenario!

Coming back. I’ve tried to install RockStor 3.9.1 several times, but the installation process fails on boot with sympthoms described at this thread:

Key three error messages at the installation log are:

*ERROR* timed out waiting for Punit DDR DVFS request
dracut-initqueue[565]: Warning: dracut-initqueue timeout - starting timeout scripts
dracut-initqueue[565]: Warning: /dev/root does not exist

My hardware is a GigaByte GA-N3150N-D3V motherboard and SanDisk UltraFit USB3.0 key (however, installer fails even without plugging USB key).

I’m blocked for the moment.

@Igor_BAREEV Welcome back to the Rockstor community.

Bit of a long shot but have you tried turning on legacy boot for that hardware, I’m pretty sure there are outstanding issues with UEFI install/boot. But only a suspicion. I’ve successfully installed on an ASRock N3700-ITX test machine here though I’ve since updated the bios so will try again, hopefully in the near future, though it probably won’t be until the next iso release is re-based on the about to be released CenOS 7.4 (1708):

Also it would probably have been best to start a new thread, or add to your referenced thread, on this install (rather than update) issue.

Hope that helps.