Rename Pools and Shares

Hi,

is there a way to rename pools and shares after they have been created and are in use without deleting them and loosing data?
I do not know if btrfs is actually supporting it or not, but if the Web-UI should support it as well, as storage grows, naming has to be changed as well sometimes.

1 Like

I think this is possible. Renaming Shares can be done even now in a round about way by creating a Clone and deleting the Share afterwards. Pool and Share renaming should be implemented separately. So, here are the two issues for them:

this is great and could work.

thanks

I had to search for this as I have recently tried testing replication send/receive between two Rockstor appliances. I don’t know if there is a better way for naming the “received” or not, but it is rather “ugly”.

For example: I have simple shares names, such as “Music”, or “Movies” on my primary Rockstor unit (with appliance ID 00000000-3caf337c-d0a4-48d2-af6a-e77478ece987) when I set up a send/receive job between appliances, the receiving Rockstor unit now has a share named something like “00000000-3caf337c-d0a4-48d2-af6a-e77478ece987_Music” and “00000000-3caf337c-d0a4-48d2-af6a-e77478ece987_Movies”. So I will have to rename these I guess. Not sure why the key id is appended( by design??). Your replication blog/docs are older version of Rockstor and are screens and info are completely different now. I may not have done my “add appliance” correctly/optimally to each unit as it is different compared to older Rockstor version docs show in the blog.

I technically dismantled the test unit 2 (receiving unit) ATM. It has been just for testing, with some old hardware I had laying around. I am upgrading to beefier hardware in that PC case. But I can temporarily reassemble it if you need more info.

I would like to rename my plex-media share to media-storage. So, I cloned plex-media and named it media-storage (as per this post) with the intent of deleting the old plex-media share, eventually. The plex-media share is not a clone but created prior to Plex rock-on installation. Things worked fine but a little unexpected.

…the unexpected things are:

1.) why is the cloned share reporting 0 bytes usage? I was expecting it to be incidental in size to the cloned share.

2.) if they are clones why they look different to Ubuntu?

Just want to make sure there is no weirdness going on, before I proceed using the media-storage and nuking the plex-media share.

UPDATE

scratch #2 both shares look the same to Ubuntu now.

Still wondering why clone is reporting 0 bytes in rockstor?

From command line please, how can I rename a pool? Is it a btrfs filesystem?

Hi @Argo

You’d want to do something like:

sudo btrfs filesystem label <mountpoint> <newlabel>

However, I’m not sure how Rockstor itself with handle a label change, so I would proceed with caution.

1 Like

@Argo A belated welcome to the Rockstor community.
As per @vesper1978 warning:

Rockstor is not yet ‘wise’ to pool label changes however we do have this planned:

and as it goes I’ve made some progress towards this in my current issue pool resize disk removal unknown internal error and no UI counterpart #1722 which improves some of the disk / pool scan mechanisms. The code should be ready shortly. And although with it we are not quite there it’s pretty close. We have also made some progress a while back towards the sister issue of:

So in time we should be good on these fronts. As is a pool or share rename at the command line may have undefined consequences.

Hope that helps.

Thank you @vesper1978 . I ended up doing the above.

And thank you @phillxnet.

In all honesty - pardon me for saying so: I will end up proceeding without Rockstor. At least for the foreseeable future.

In order to make that constructive, let me try to explain my reasons.

I am commenting as both a software and a devops engineer. By that I mean: I understand my share about the process(es) involved in software development.

  1. No UEFI support. Recent Linux kernels support EFISTUB, they can be booted directly from a suitable boot loader.

My BIOS doesn’t even support booting BIOS devices as primary devices. This is a problem: I have needed to be able to fallback. I have needed my multiboot, rather than playing around with live USBs in case anything happens.

  1. I set Rockstor up. I started it. I imported my BTRFS Raid 1. This went well.

Then I tried to rename my pool. Here I am.

As you have pointed out, the command to rename a volume is reasonably simple. There is no way I am going to go around squinting to guess which pool I am on. Nope. No.

  1. BTRFs commands are proving to be straightforward.

  2. The UI lacks flexibility. It has absolutely positioned elements, HTML tables without dynamic options. It’s pretty rigid. Exposing the stylesheet for change would make it themable.

Componentizing the interface with a view library (like React) would make it easier to scale.

I was about to propose contributing at least a couple of PRs toward that.

But as it stands, a fresh Linux is a clearer starting point. I am just better off starting my btrfs-and-nginx-powered solution.

I hate the way I sound when saying that, but. It is true. I have the need so this is what I’ll do.

(now, if Rockstor comes a little further, perhaps with the rebase to OpenSuse? I really hope I’ll have to look back. I was rooting for something like that).