'Requested boot drive "sda" doesn't exist or cannot be used.'


In a nutshell, the installer won’t let me use a USB stick to install to.
I’m trying to move from FreeNAS, where such a thing could be done.

The graphical installer doesn’t work so I’m in the text interface and auto config of installation destination fails.

At first I had my 2 HDDs (sda, sdd) and my target USB stick (sdc) connected and deselecting the sda HDD then selecting only the USB stick at sdc failed.
Then I tried to disconnect the 2 HDDs only to keep the source and target USB sticks. Auto config failed and after going through manual config of the installation destination (select USB stick, “Use All Space”, “Btrfs”) it says

storage configuration failed: The following problem occurred on line 33 of the kickstart file:

Requested boot drive "sda" doesn't exist or cannot be used.

Could it be the installation destination is hardcoded as sda?

I tried to tweak the BIOS so that removable devices take precedence in the devices order (not boot order – this was setup alright to boot from removable first), now the order is as follows:

  • sda installation source USB stick
  • sdb (hopefully) installation target USB stick
  • sdc HDD1
  • sdd HDD2

Although the USB come first in the list (and the installation destination selection screen also shows it this way), nope, it still requires the destination to be sda or nothing :unamused: