Reset root password - rockstor built on openSUSE installer


I tried to reset my root password according to these instructions:
But on my openSUSE” Kiwi-ng created installer there is no Troubleshoot option:

How can i do that?

@vtzsolt Welcome to the Rockstor community forum.

Yes, we have an outstanding issue to update that doc section here:

In that issue @Hooverdan provides the current work-around. Just be sure to retrieve a matching version of the rescue CD indicated by @Hooverdan in that issue to the version of Leap your install is based on.

Hope that helps.


@phillxnet Thank you for your reply.
I’ve tried the mentioned solution but unfortunately did not worked for me.

After that I tried the single user mode method and I successfuly reset my root password.
In grub I used “e” to edit the menu
At the end of line that begins with “linux” appended this text : init=/bin/bash

Pressed F10 and booted into emergency mode
Remounted the root file-system:
mount -o remount,rw /
Reseted the password:


@vtzsolt Glad you got this sorted.

Thanks for sharing your work-around here, we definitely need to get those docs updated with know working (and easy) methods.

Nice find re the init kernel boot mode: ideally we want something way less fiddly than that but if it works - all good.



At the time of installation (Dec 21) not being aware of linux needs in the world of passwords etc, I cannot remember what I used for the root user and password.
I did photograph the screen and the only visable word that could be taken as a username is actually a possible password but i dont think the password would be visable.
Would it not be easier to disconnect the data drives, re install to the latest version (knowing what to record this time :flushed:), then reconnect the data drives to continue operations? The process explained in the above post was beyond my ability.
Can the Rockstor-NAS shell be accessed through an Android tablet? Possibly I am attempting something that wouldn’t work anyway.
Once again thanks for your help

@Mike-B Hello again.

When you say root user, are you referencing the real “root” user name (overall linux system administrator) pass. This one is set during the install stage at this point:

And their user-name is literally “root”. And yes, that is definitely the single most important password to take a note on :).

Or are your referencing the Web-UI admin user that is named whatever you entered at this stage of the original setup:

“admin” in that first picture.

Just wanted to clarify.

Also, if you can hang on bit regarding re-installing. We are due in the next few weeks (hopefully sooner) to release new installers based on 15.5 with the 5.X.X-0 stable release candidates. Once we get a few show-stopper bugs sorted.

Hope that helps.

1 Like

@phillxnet Thanks for the reply
Yes, it was the “real” root that is set during installation, The web ui admin user is no problem as its used regularly.
My solution would work?
I can wait for the next release as its not too far away.

@Mike-B yes, your solution would work. Since you still have the WebUI access, you can pull the configuration backup to simplify your re-install (which I think you’ve done many a times before, during your experiments).
If you have the time, you can follow @phillxnet recommendation to wait for the next stable, but if you want to “practice” the reinstall you can of course do that with the latest 4.x stable …


Thanks @Hooverdan
Think i will wait for the next release, I will also have to work through your suggestion on how to practice a reinstall.
My brain doesn’t function as fast as it used to :flushed:.
Thanks again

1 Like