[Resolved] Can't get at the Rockon "All" tab

Hi, I was having some spurious Plex errors so I decided to start again by uninstalling Plex and deleting the plex-config share. (For good measure I did the same with Tartulli and the tartulli-config share).

I remade the plex-config share and re-installed Plex. However it flagged an error message so, rather than rush it, I deleted the plex-config share again and uninstalled Plex to go back to when I had more time.

Now when I try to install any Rockon, the “All” page ‘refreshes’ itself and it goes back to the “Installed” page after about 5 seconds which prevents me from installing anything. Everything else seems to behave normally.

Any advice about how to resolve this behaviour? Thanks.

@kingswindsor, when you uninstalled Plex, did you also run the script to get rid of any remnants?

/opt/rockstor/bin/delete-rockon 'Plex' ?


That often times cleans up weird behavior associated with uninstall/reinstall issues.

You could do the same thing for tautulli

1 Like

Hi @Hooverdan
Thanks for the suggestion but unfortunately the script doesn’t seem to run for me. It throws up these errors

Traceback (most recent call last):
File “/opt/rockstor/bin/delete-rockon”, line 37, in
import scripts.rockon_delete
File “/opt/rockstor/src/rockstor/scripts/init.py”, line 6, in
File “/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/init.py”, line 17, in setup
configure_logging(settings.LOGGING_CONFIG, settings.LOGGING)
File “/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/conf/init.py”, line 48, in getattr
File “/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/conf/init.py”, line 44, in _setup
self._wrapped = Settings(settings_module)
File “/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/conf/init.py”, line 92, in init
mod = importlib.import_module(self.SETTINGS_MODULE)
File “/usr/lib64/python2.7/importlib/init.py”, line 37, in import_module
ImportError: No module named settings

and the Rockon page behaviour is the same. I should have said that everything is up-to-date and I have re-booted a couple of times.

@kingswindsor Hello there.
I can chip in on this one maybe:

Did you run the script as the “root” user. That may be important in this case.

Hope that helps.


Thanks @phillxnet, I should have thought of that but it is a while since I set it up. But it worked perfectly - almost. I could access the ‘All’ page but Plex was missing and the Refresh button throws up errors. A reboot proved to be what was required to get round that.