[resolved] SMB Share read-only while in guest mode

Edit: Upgrading from 3.8.16-16 to 3.9.0-7 resolved my guest account access issue.

Hey, so I am attempting to switch from FreeNAS to Rockstor. To do this I need two things to work in the same directory:

I’m getting stuck on SMB sharing with guest accounts. The shares are read only but I’m at a loss as to why.
Samba is set to the workgroup of:

Rockstor is currently version 3.8.16-16
The global config looks like this:
log level = 3
map to guest = Bad User
cups options = raw
log file = /var/log/samba/log.%m
printcap name = /dev/null
load printers = no

and the share looks like this:
root preexec = "/opt/rockstor/bin/mnt-share test-share"
root preexec close = yes
comment = Samba-Export
path = /mnt2/test-share
browseable = yes
read only = no
guest ok = yes
admin users = nfsnobody
public = yes
guest only = yes
guest account = nfsnobody

The file permissions of the folder are:
[root@rockstor test-share]# ls -la
total 0
drwxrwxr-x 1 nfsnobody nfsnobody 18 May 28 08:48 .
drwxr-xr-x 1 root root 88 May 27 22:05 …
drwxrwxr-x 1 nfsnobody nfsnobody 8 May 27 22:54 .scpy
drwxr-xr-x 1 nfsnobody nfsnobody 0 May 27 22:54 test

As far as I can tell this should work…
The SMB logs show this:
[2017/05/28 08:50:46.303893, 3] …/source3/auth/auth.c:178(auth_check_ntlm_password)
check_ntlm_password: Checking password for unmapped user [MicrosoftAccount][mathew.w.keith@gmail.com]@[DESKTOP-ILR26S4] with the new password interface
[2017/05/28 08:50:46.303910, 3] …/source3/auth/auth.c:181(auth_check_ntlm_password)
check_ntlm_password: mapped user is: [ROCKSTOR][XXXXXXXXXXX]@[DESKTOP-XXXXXX]
[2017/05/28 08:50:46.303953, 3] …/source3/auth/check_samsec.c:400(check_sam_security)
check_sam_security: Couldn’t find user ‘XXXXXXXXXXXXXXXX’ in passdb.
[2017/05/28 08:50:46.303972, 2] …/source3/auth/auth.c:315(auth_check_ntlm_password)
check_ntlm_password: Authentication for user [XXXXXXXXXXXXXXXX] -> [XXXXXXXXXXXXXXXXXX] FAILED with error NT_STATUS_NO_SUCH_USER
[2017/05/28 08:50:46.303993, 3] …/source3/auth/auth_util.c:1602(do_map_to_guest_server_info)
No such user XXXXXXXXXXXXXXXXXXX [MicrosoftAccount] - using guest account

Also I’m curious about the file layout. why are there two folders that link to the same place?

is there a difference between the two I should know about?

Thanks for your help.

I tried working on the NFS portion in the mean time and it’s looking like rockstor won’t work for me, as there are no options to map users to NFS. I would need to be able to do that so that guest access worked…