Restoring Configuration Does Not Seem to Work

Based on the information found on this page: Configuration Backup and Restore — Rockstor documentation

I would expect users, samba exports, and more to be restored after reinstalling Rockstor and restoring from the configuration. After letting it run over night, only a single export was created. No additional users or Rock-Ons were installed.

I rebooted the server and ran the configuration restore again. This time, three Rock-Ons were installed, one additional user, but nothing else seemed to be done. Should I just keep using the restore configuration option until everything gets installed and set up again?

JSON formatter is reporting an error in the file. Should this be a valid JSON file?

Edit: There were two lines in the file, each line on its own was a valid JSON entry. Is this OK?

@Noggin, actually yes. I even opened an issue on this in the past, and we agreed that a small explanation should be added to the Rockstor documentation (which has not been picked up/completed by anyone). For reference, the github issue:

Which does not further explain why your backup is giving you trouble this way. Can you see other errors in the rockstor.log? If I remember correctly, Rockstor logs success/error messages related to the backup restoration. And, it definitely should not require an overnight run to get more stuff restored…

@Flox, any pointers on what else to check?

1 Like

One issue might be that Plex is just stuck on installing. I’m not sure what to do about that. If I ssh in and run docker ps only lists mariadb, duckdns, syncthing, and nzbget.

If I run docker images I get a lot of images, some are duplicates. I see a plex images that was created 2 years ago and a aplex image that was created 4 days ago. Should I go through and delete the old images?

Is there a way to cancel the pending Plex installation?

I believe, if you go the command line (if you use the system shell on the WebUI you will have to invoke sudo for these things) and execute the commands found under this link you should be able to get rid of the hanging installation:

It’s curious that you have the older images around. It might be a good idea to remove these images (after you tried the above to get a clean baseline again).

Were you using the watchtower Rock-on before without the cleanup (WATCHTOWER_CLEANUP) option?

Thanks. I gave that a shot, did poetry run delete-rockon Plex but the Rock-ons interface still shows that it is trying to install Plex. I then removed the old Plex docker image and tried to turn the Rock-on service off then back on again, it just didn’t want to cooperate. I’m doing a reboot now. If this takes too much more time, I think I’ll reinstall fresh again, delete all the old docker images, and THEN try to restore from the config script.

Side question, is Rockstor’s web interface usually slow? It takes 30 seconds to a minute to load most pages. Has been that way from the very first day I started using it a few years ago.

Edit: I think I had old Rock-on images because I put my Rock-on’s root on my bulk storage drives. This time after I installed the OS, I went to the directory, made a backup directory, and moved all the old stuff into there. Then I turned on the Rock-on service and began the restorage from the config file.

Edit 2: I wasn’t using the Watchtower Rockon.

Edit 3: Making progress! Plex is now installed, took a few tries. Kept have to delete the docker container, image, and running the poetry thing, but it is up and running now. But dmesg is showing errors on ATA1 and ATA3 (/dev/sda and /dev/sdc) so I guess I’m going to be looking into that next…