Rock-on update Error code

(Commercial Support) for expedited support directly from the developers.]

Brief description of the problem

Issue during rock-ons update

Detailed step by step instructions to reproduce the problem

[write here]
Error occurred during the rock-ons update

Web-UI screenshot


Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/src/rockstor/storageadmin/views/", line 107, in post self._create_update_meta(r, rockons[r]) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/utils/", line 145, in inner return func(*args, **kwargs) File "/opt/rockstor/src/rockstor/storageadmin/views/", line 268, in _create_update_meta handle_exception(Exception(e_msg), self.request) File "/opt/rockstor/src/rockstor/storageadmin/", line 47, in handle_exception trace=traceback.format_exc()) RockStorAPIException: ['Cannot add/remove volume definitions of the container (owncloud-official) as it belongs to an installed Rock-on (OwnCloud-Official). Uninstall it first and try again.', 'Traceback (most recent call last):\n File "/opt/rockstor/eggs/gunicorn-19.7.1-py2.7.egg/gunicorn/workers/", line 68, in run_for_one\n self.accept(listener)\n File "/opt/rockstor/eggs/gunicorn-19.7.1-py2.7.egg/gunicorn/workers/", line 27, in accept\n client, addr = listener.accept()\n File "/usr/lib64/python2.7/", line 202, in accept\n sock, addr = self._sock.accept()\nerror: [Errno 11] Resource temporarily unavailable\n']

Hi @OSConvert, and welcome to the community!

First, sorry for not getting back with you earlier… things are quite busy for me at the moment so it was difficult to find some time. It still is the case, but I will point you towards another thread in this forum with the same error:

As you can see in this post, this error reflects a rather complex situation related to the update of the rock-ons-related information in the database, and can result from a variety of factors. I would thus suggest you to try the steps listed in the post listed above and see how it goes first.

For the same reason, would you mind giving some additional information on your setup? It may help pinpointing the cause of the error and thus better solve the issue. For instance:

  1. Rockstor version
  2. Drives and pool(s) setup
  3. first time clicking the Update button on the rock-ons page?
  4. Have you ever installed or tried to install the Owncloud-Official rock-on in the past?

Sorry for the rather rushed reply, but I hope it will at least help you get on the right track.


Thanks for pointing me in the right direction. The tip fixed the problem.

1 Like

Thanks for letting us know and glad you’re now all sorted out!