Rock-on will not install after uninstall

Hello all,
I had an issue with my 16gb flash drive running Rockstor filling up with logs Philxnet was kind enough to help me get the system back up and running. Unfortunately I believe the the original issue was one of my own creation and somehow I got my Rock-ons using my flash drive. To make a long story short, somehow in my turning off, and uninstalling of my rock-ons I have managed to bugger something up with them as well.

If I try to reinstall Lazy-librarian, NZBget or Transmission I go through the steps in the wizard and nothing happen, when I check the list of Rock-ons I see

lazylibrarian is an automated ebook downloader for NZB and Torrent.

Failed to install in the previous attempt. Here’s how you can proceed.
Check logs in /opt/rockstor/var/log for clues.
Install again.
If the problem persists, post on the Forum or email"

for each one I try to install, If I install a Rock-on for the first time it works fine. I have tried deleting shares and creating new shares but that hasn’t helped.
Once again I am out of ideas and asking for a helping hand.



Could you please provide the logs from /opt/rockstor/var/log from ~5 minutes before to ~5 minutes after an installation attempt?

Also, the output of the following commands might provide some insight:

docker ps
docker images
docker logs --since 15m --until 5m

Please note that in the ‘docker logs’ command above, you will need to adjust times accordingly to when you attempted the installation.
IE: If you attempted to install the Rockon 45 minutes ago, you would use

docker logs --since 50m --until 40m

It might be worth you attempting the installation of a Rockon again so that you can get an accurate fix on the timing.

I apologize for my lack of knowledge but I am unclear as to which log you would like from /opt/rockstor/var/log

Last login: Mon Feb 26 08:26:11 2018 from chas2015.lan
[root@rockstorage ~]# cd /opt/rockstor/var/log
[root@rockstorage log]# dir
gunicorn.log supervisord_gunicorn_stdout.log
rockstor.log supervisord.log
rockstor.log.1 supervisord_nginx_stderr.log
rockstor.log.2 supervisord_nginx_stdout.log
rockstor.log.3 supervisord_ztask-daemon_stderr.log
supervisord_data-collector_stderr.log supervisord_ztask-daemon_stdout.log
supervisord_data-collector_stdout.log ztask.log
[root@rockstorage log]#

I attempted to install LL @ 11:00
docker logs --since 15m --until 5m at 11:06

[root@rockstorage ~]# docker logs --since 15m --until 5m
unknown flag: --until
See ‘docker logs --help’.

Not sure what I am doing wrong

Sorry I forgot to post the first 2 prompts

[root@rockstorage ~]# docker ps
[root@rockstorage ~]# docker images
linuxserver/booksonic latest 1ce1650f8439 2 days ago 202 MB
linuxserver/nzbget latest 396a63791c4c 7 weeks ago 76 MB
linuxserver/deluge latest 3094dc85b421 2 months ago 175 MB
linuxserver/lazylibrarian latest 01ce5b7d90dd 2 months ago 194 MB
jenkins latest 5fc84ab0b7ad 2 months ago 809 MB
dperson/transmission latest 125d2723f80b 2 months ago 13.6 MB
haugene/transmission-openvpn latest eb76523d2aea 3 months ago 361 MB
dbarton/utorrent latest b3eb23ebb76c 24 months ago 138 MB
[root@rockstorage ~]# docker logs --since 160m --until 140m

I am not sure what this means but I assume it is related to the issue. When I try to delete the Rockon_root share i receive this error.

        Traceback (most recent call last):

File “/opt/rockstor/eggs/gunicorn-0.16.1-py2.7.egg/gunicorn/workers/”, line 34, in run
client, addr = self.socket.accept()
File “/usr/lib64/python2.7/”, line 202, in accept
sock, addr = self._sock.accept()
error: [Errno 11] Resource temporarily unavailable

I think I have got dockers working, I deleted the snapshots of the rockon root share, then deleted the share. Turned rockons off, then set a new rockon root share then installed LL.

It is up and running now I just need to see if I can get it configured correctly this time.

Thanks to all that helped.

@kysdaddy Glad you’re sorted again.

Although you’ve already worked this out I’ll pop it in anyway.

This can happen if it’s still configured as the Rock-ons-root share, changing the Rock-ons service config to use another share first, then you should be able to delete the ‘old’ rock-ons-root share.

Well done sorting it out. And given no data or config should be on that share, reinstalling the Rock-ons while using the same config / data shares for each should leave each Rock-on back where it was. Hopefully.

So far so good, thanks again for your help.