Rockon fails indefinitely after install

I want to start a discussion about a recent issue. I’d like to add more detail now, but will only be able to describe it.

I forked the GitLab rockon. It installed and I had it running through a proxy. The next day it showed in a stopped state with an unknown error. I tried uninstalling. That didn’t complete after six hours. I used the delete-rockon command. It finally showed uninstalled in the GUI.

The problem is that it will not install again. No changes to the rockon. I tried recreating the shares. I’d rather not delete the data share. But I finally did and it still didn’t install with all new shares. Any ideas?
I’ll have to check again when I have access, but earlier when I was trying the install of the rockon several times after the uninstall, there were no logs for a rockon failure during the time of the install.

Also this is occurring on Rockstor 3.9.2-10 (stable)
I read through a year old post that sounds very similar to what I’m experiencing. It seems similar to this issue because I also noticed Rockons, “stuck” in an uninstalling state. I haven’t noticed rockons stuck in any other state. And I’m now very concerned about uninstalling other rockons, which was something I was doing regularly while testing Rockons I’ve been writing and testing.

Well, last night, after work, I reviewed the Rockon section of the guide and went over the systemd logs for docker.service and rockstor.service. I found some container output. But none of the output was from the GitLab container starting, e.g. ‘journalctl -u docker.service |grep -i gitlab’. So, with the sparse logs I decided to just run the docker run command. I may look over the wiki further, sometime. Albeit, since it is working, I’m going to just try using docker compose to run this container for now. This may not be a solution for starting the Rockon in the GUI. Although, given that this is just for personal use, I’m not that interested in operational consistency, ATM.