RockOn Installation Failing

I am trying to install the OwnCloud RockOn and it keeps failing. docker logs show the following but I am not sure what I am doing wrong to get this:

[124] ( root:/var/lib
$ docker logs owncloud-postgres
chown: changing ownership of ‘/var/lib/postgresql/data/btrfs/subvolumes/8379a7255d3ced1aad294a0e48fe7290d55acee3df314fd357888f36d28ca714/proc/fs/nfsd’: Operation not permitted
chown: changing ownership of ‘/var/lib/postgresql/data/btrfs/subvolumes/8379a7255d3ced1aad294a0e48fe7290d55acee3df314fd357888f36d28ca714/proc/sys/abi/vsyscall32’: Operation not permitted
chown: changing ownership of ‘/var/lib/postgresql/data/btrfs/subvolumes/8379a7255d3ced1aad294a0e48fe7290d55acee3df314fd357888f36d28ca714/proc/sys/abi’: Operation not permitted
chown: changing ownership of ‘/var/lib/postgresql/data/btrfs/subvolumes/8379a7255d3ced1aad294a0e48fe7290d55acee3df314fd357888f36d28ca714/proc/sys/debug/exception-trace’: Operation not permitted
chown: changing ownership of ‘/var/lib/postgresql/data/btrfs/subvolumes/8379a7255d3ced1aad294a0e48fe7290d55acee3df314fd357888f36d28ca714/proc/sys/debug/kprobes-optimization’: Operation not permitted
chown: changing ownership of ‘/var/lib/postgresql/data/btrfs/subvolumes/8379a7255d3ced1aad294a0e48fe7290d55acee3df314fd357888f36d28ca714/proc/sys/debug’: Operation not permitted
chown: changing ownership of ‘/var/lib/postgresql/data/btrfs/subvolumes/8379a7255d3ced1aad294a0e48fe7290d55acee3df314fd357888f36d28ca714/proc/sys/dev/cdrom/autoclose’: Operation not permitted
chown: changing ownership of ‘/var/lib/postgresql/data/btrfs/subvolumes/8379a7255d3ced1aad294a0e48fe7290d55acee3df314fd357888f36d28ca714/proc/sys/dev/cdrom/autoeject’: Operation not permitted
chown: changing ownership of ‘/var/lib/postgresql/data/btrfs/subvolumes/8379a7255d3ced1aad294a0e48fe7290d55acee3df314fd357888f36d28ca714/proc/sys/dev/cdrom/check_media’: Operation not permitted

Based on the logs it looks like there are two problems:

  1. I cannot set the config/DB storage location to be the automatically created “rockons” volume - Why is this? And if it is by design why is it shown as an option? Setting all 3 of the storage (config/data/db) to my personal media volume made those errors go away.

  2. it’s timing out after 600 seconds - seems like there would be a smarter way to do this via polling docker or something or letting me set the timeout value in cases were it is just going to take longer.

Not sure how to proceed.

Hi @nandor,

I have a couple of ideas related to what could be wrong there.

First, given the logs you provided (here and in one of your other threads), it seems to me you are trying to install the rock-on named OwnCloud… I will thus assume so below, but please correct me if I’m wrong.

The repeated operation not permitted messages in your log seems to indicate some permission issues with the shares you selected. A screenshot of your setup (clicking on the little wrench icon next to the installed rock-on, or the summary table with list of shares and ports, etc… at the last step of the install wizard) could thus be helpful.

Note, however, that this rock-on is one of the first one that were made available in Rockstor and is thus based on a relatively old docker image (Docker). As you can see in that link, the version of Owncloud itself is rather old, and I would thus recommend not to use that one, but one of the other available (owncloudHTTPS, or OwnCloud-Official), which should provide you with a more up-to-date version of Owncloud. There are plans on improving the display of such information in the webUI to make that easier. Note that there is some work on Nextcloud rock-ons as well if you prefer.
The reason I’m bringing this up, is due to the fact that when I tried to install this rock-on as a test, it fails due to a problem with the postgres initialization, which I suspect is itself due to the fact that a much newer image than what was available at the time of this rock-on write-up. Indeed, this rock-on has a custom install script to setup the postgres database which probably isn’t compatible anymore with the much newer version of postgres pulled by docker as of this writing. In details, the postgres version required for this rock-on was 9.5, but the current latest image pulls 11.4:

[root@rocktest ~]# docker exec -it owncloud-postgres bash
root@2d277de939b2:/# psql --version
psql (PostgreSQL) 11.4 (Debian 11.4-1.pgdg90+1)
root@2d277de939b2:/# [root@rocktest ~]#

Although the version 9.5 is indeed specified in the related rock-on, this is currently ignored but a fix has recently been merged, which would allow the older version to be used instead.

This may be included with the next Rockstor release (need @phillxnet’s confirmation on that), and should thus be working again then.

I would note again, however, that this rock-on installs a rather old version of owncloud and would thus recommend you to try one of the other options available (listed above). There also are a few threads here related to these other options if you’d like to have a look… see the one below as an example (sorry for not being more exhaustive for now, I’m quite in a hurrry unfortunately):

Sorry for the somewhat rushed post, but I hope this will still prove a little helpful to get you on track.
Let us know how it goes!

1 Like

I just realized I missed your most recent post, so I’ll answer that now.

By “rockons” volume, do you refer to the rockons_root share you selected during the configuration of the rock-on service? If yes, note that this share is only used by docker to store images, containers layers, and all other files needed by docker to run. As a result, it should not be used for any other purposes. See the documentation:

It usually is recommended to create dedicated shares for each volume required by each rock-on in order to limit the risk of conflict(s) between rock-ons.

The timeout is related to the failure of postgres to start, which I suppose is related to my previous post above.

Hope this helps.

1 Like

Super helpful @Flox! Thank you! I did not realize that some RockOns are deprecated. UI Elements to that effect would indeed be helpful. Trying to install OwnCloud-Official now and it worked!

Glad you got it sorted!

The OwnCloud rock-on is not deprecated per se, but there were some shortcomings related to its use. I thank you for reporting this one as I wasn’t aware of it. As mentioned above, there is a fix about to be released (I believe) that should improve the situation.
Note that there is a lot ongoing development related to the rock-ons system, affecting their base features, robustness, and how they are presented and integrated with the UI, so there’s a lot more to come in the future. I personally have several of those in the works, but I’m trying to focus my efforts on helping with the openSUSE rebase first as this is a priority in my opinion. The rock-ons related works should come up very quickly after that, however.

Thanks again for your report, and don’t hesitate to let us know how it goes!

@Flox and @nandor Re:

To confirm, yes, given the indicated pull request / fix for docker tags has now been merged into rockstor-core master it will appear in the next Rockstor stable release which is due to be 3.9.2-49.

As @Flox mentioned this fixes a bug where we ignored docker tag stipulation and always fetched the ‘latest’ tagged image. Not a problem for the vast majority of our submitted Rock-ons but does end up breaking some. Thanks again to @Flox for reviewing that pull request.

@nandor I noticed you mentioned:

There are no (as yet) automatically created btrfs subvolumes (Shares in Rockstor speak) on data drives. But prior existing shares will re-appear if their pool has been imported from a prior Rockstor install.

It may be that your browser is simply showing this by way of a prior cached entry in the same box.

Hope that helps.