Rockons-metastore jsons missing


Im working on new plex JSON, as i think the image has changed. The result was that I could log in to the web UI, but not connect to server. So I checked the image, and updated according to requirements.

However, for testing before potentially submitting the update i do like to test to see that they work.
And the JSON from rockstor-metastore is not showing up. This happened after updating to latest testing. I have cleaned uninstalled all rock-ons and cleaned docker volumes.

Nothing helps

I’m currently having a similar problem. i noticed the list of available rock-ons stopped at Sonarr. i changed the name of the rock on from “TVheadend” to “AVheadend” and i showed up in the top of the list, Sonarr how ever is not showing up now.

I wonder if this is due to web-layout issue. I.e. there is space for only that many rock-ons.

@bug11 Just linking back to the issue you opened on the same (thanks):
"Rockstor-metastore jsons not loading"
I wonder if this issue doesn’t belong in rockstor-core though as looks more related to core processing and display of available rock-ons as you suggest.

Edited: I may be in error here on the wrong repro-bit, just found an issue with rockstor-registry, will report back once I’ve looked into it a bit more.

@HBDK Welcome to the Rockstor community by the way and thanks for chipping in on this one.
I see only 15 available Rock-ons but there are currently 16 available. @bug11 and @HBDK do you have the same numeric limit?

so counting running rock-ons and available rock-ons i have 15. it reminded my that i had sickbeard running the other day and when i later added more .json files it stopped showing on the list of running rock-ons but the contianer still worked as expected and showed up when i ran “docker ps -a” from the command line. @phillxnet thanks for the welcome…

@HBDK Thanks, narrowing this one down now hopefully.

i have 17 rockons.

However i have 2 that is from the metastore running. I dont know what is happening, because after a reboot of the server, I could find my own rockons from the metastore.

But the funny thing now, I have rewritten Plex, and put it in metastore with the name plextronder88.JSON. when loading the rockon page, I get my own plex rock-on and not the official rock-on.

There is something going on with the web UI.

@bug11 Thanks for the extra info, I’m having a quick look at this now.

@bug11 and @HBDK and @hxdai I’m afraid my quick look didn’t find anything other than “symform entry missing in root” which I don’t think is the cause of these other missing Rock-on entries. Not very familiar with this code though so could still be something obvious. Is there anything that looks interesting / related in:

tail -f /opt/rockstor/var/log/rockstor.log

when refreshing the Rock-ons page or using the Update button on that page.

@hxdai I’ve installed Transmission on a freshly updated system (3.8-12.07) and rebooted but all appears as expected with Transmission showing as installed and no longer showing in the “All” tab so haven’t yet reproduced any missing installed Rock-ons.

After my update to 3.8-12.07 the total installed and available Rock-ons count is now 16 which is as far as I know correct ie no local jsons added. If my pr is not a mistake then this should bring that number to 17 with the addition of symform.

@suman Could this be related to the commit a couple of days ago:-

It is. By default, maximum number of rock-ons that can be displayed was 15 which I fixed in that commit. However, this effects the Stable folks as they won’t get the change until the next update. Meanwhile we don’t have separation between stable and testing rock-ons, so stable folks are getting every rock-on soon as it’s added. Long story short, some embarrassing stuff here we need to improve on and also get the stable release going soon.