RockOns Page very often just blank

Hello,

very often, my rock-ons page is just blank, like I do see the normal headline with the different categories and pages and even the bar on the left side, but the part where it would list the installed/all rockons is just blank

I tried to gather some more information:

  • reloading does not help
  • closing and opening a new tab does not help

while typing this post, I had a rockons tab open with a blank page and the browser console to log the network requests. Two requests took 1.4 minutes to complete, the last one 1.8
image
I also had the logfiles open and I saw this and I believe right after that it finally loaded (I can’t say for sure as I didn’t have the tab visible at the time):

==> gunicorn.log <==
[2021-04-26 19:25:48 +0000] [1796] [CRITICAL] WORKER TIMEOUT (pid:18305)
[2021-04-26 19:25:48 +0000] [18305] [INFO] Worker exiting (pid: 18305)
[2021-04-26 19:25:48 +0000] [25383] [INFO] Booting worker with pid: 25383

If I can provide you with any more logs or information, just let me know.

1 Like

@Marenz Thanks for the details report.
Yes, those kinds of delays will for sure given timeouts.

What version of Rockstor are you experiencing this on?

Could you also given an indication of the kind of hardware you are experiencing these delays on as well. We have added a degree of complexity to the rock-ons of late (rock-nets) and it may be we are in need of some optimisations in this area. But it would help to know what setup you have where these kinds of delays are taking place.

@Flox may have some more questions on this but lets get some details of the hardware in this thread for the context. Also the number and type of rock-ons you have running may help with narrowing down whats going on here.

We haven’t had another report of this behaviour either on the forum or via support so if others are also seeing this then please chip in, again with the hardware and rock-on number/nature you are experiencing this delay with.

Thanks again for the report.

1 Like
  • version is 4.0.6-0.
  • CPU is Intel® Pentium® CPU G4560 @ 3.50GHz
  • Ram: 32 GB ECC.

In fact, here is the hwinfo output:

rockstor:~ # hwinfo --short
cpu:
                       Intel(R) Pentium(R) CPU G4560 @ 3.50GHz, 3500 MHz
                       Intel(R) Pentium(R) CPU G4560 @ 3.50GHz, 3500 MHz
                       Intel(R) Pentium(R) CPU G4560 @ 3.50GHz, 3500 MHz
                       Intel(R) Pentium(R) CPU G4560 @ 3.50GHz, 3500 MHz
graphics card:
                       Intel HD Graphics 610
sound:
                       Intel 100 Series/C230 Series Chipset Family HD Audio Controller
storage:
                       Intel Q170/Q150/B150/H170/H110/Z170/CM236 Chipset SATA Controller [AHCI Mode]
network:
  eth0                 Intel I210 Gigabit Network Connection
  eth1                 Intel Ethernet Connection (2) I219-LM
network interface:
  vethfe8c457          Ethernet network interface
  eth1                 Ethernet network interface
  veth6f7dff3          Ethernet network interface
  docker0              Ethernet network interface
  lo                   Loopback network interface
  eth0                 Ethernet network interface
disk:
  /dev/sdd             TOSHIBA HDWN180
  /dev/sdb             TOSHIBA DT01ACA3
  /dev/sdc             TOSHIBA DT01ACA3
  /dev/sda             INTENSO
partition:
  /dev/sda1            Partition
  /dev/sda2            Partition
  /dev/sda3            Partition
usb controller:
                       Intel 100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller
bios:
                       BIOS
bridge:
                       Intel 100 Series/C230 Series Chipset Family PCI Express Root Port #1
                       Intel C236 Chipset LPC/eSPI Controller
                       Intel 100 Series/C230 Series Chipset Family PCI Express Root Port #8
                       Intel Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers
hub:
                       Linux Foundation 2.0 root hub
                       Linux Foundation 3.0 root hub
memory:
                       Main Memory
unknown:
                       FPU
                       DMA controller
                       PIC
                       Keyboard controller
                       PS/2 Controller
                       Intel 100 Series/C230 Series Chipset Family Power Management Controller
                       Intel 100 Series/C230 Series Chipset Family MEI Controller #1
                       Intel 100 Series/C230 Series Chipset Family KT Redirection
                       Intel 100 Series/C230 Series Chipset Family Thermal Subsystem
                       Intel 100 Series/C230 Series Chipset Family SMBus
  /dev/ttyS0           16550A
  /dev/ttyS4           16550A

I couldn’t confirm it yet, but I suspect it is somehow related to me starting or stopping a rockon or possible (un)installing… some kind of interaction? I try to watch that.

The installed rockons are:

1 Like

Minor update: I just was confronted with a blank page again, no rockon starting/stopping done in days… so it doesn’t seem to be related to that.

1 Like