i try to migrate from OMV to Rockstor, and try also ot migrate my Docker container and DVB-S2 Card.
But i have issues to get up my DVB-S2 (DVBSKY-S952). I see the card if i check the device with lspci, but i see no /dev/dvb device.
i think because of missing firmware/drivers.
i have tried to copy FW Files to /lib/firmware, but i think, this is not the correct place in Opensuse.
Maybe someone can give me the correct documentation for installing DVB Card in Opensuse/Rockstor.

many thanks

@tango38317, welcome to the Rockstor forums.
When you run dmesg | grep -i dvb do you get anything in return?

I believe, the /lib/firmware is still the correct location (I have some other firmware for a different device in that location).

1 Like

Hello @Hooverdan,
thanks for your response :slight_smile:.

Further Information: i use PROXMOX with PCI Passtrough of the DVB Device (works on Debian).
Output of LSPCI: 01:00.0 Multimedia video controller: Conexant Systems, Inc. CX23885 PCI Video and Audio Decoder (rev 04).

But no output with dmesg | grep -i dvb

Output of lspci -nnv.

01:00.0 Multimedia video controller [0400]: Conexant Systems, Inc. CX23885 PCI Video and Audio Decoder [14f1:8852] (rev 04)
Subsystem: DVBSky S952 [4254:0952]
Physical Slot: 0
Flags: fast devsel, IRQ 10
Memory at fe800000 (64-bit, non-prefetchable) [size=2M]
Capabilities: [40] Express Endpoint, MSI 00
Capabilities: [80] Power Management version 2
Capabilities: [90] Vital Product Data
Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [100] Advanced Error Reporting
Capabilities: [200] Virtual Channel

many thanks

maybe this is my issue:
tried to search for:

dmesg | grep -i 01:100:


[ 0.412812] pci 0000:01:00.0: [14f1:8852] type 00 class 0x040000
[ 0.414089] pci 0000:01:00.0: reg 0x10: [mem 0xfe800000-0xfe9fffff 64bit]
[ 0.420540] pci 0000:01:00.0: supports D1 D2
[ 0.420783] pci 0000:01:00.0: PME# supported from D0 D1 D2 D3hot
[ 0.421666] pci 0000:01:00.0: disabling ASPM on pre-1.1 PCIe device. You can enable it with ‘pcie_aspm=force’

Maybe the missing pice_aspm is my issue?


I am reaching the end of my knowledge in this area, and I am unfortunately also not a Proxmox expert. I was wondering (from what I was reading) whether the device shows up properly when you configure the Rockstor VM? It sounds like you’ve been doing this successfully previously using OMV (on Proxmox)?
Sorry, I can’t help more, but we do have more people on the forum here, that have been working Proxmox it seems.

1 Like

thanks, you tried it.
i´ll try to install Proxmox with installed card while installing proxmox, maybe it will install the kernel module :-).
or maybe someone else has an idea how to solve it, and install the kernel module in opensuse.
many thanks

i tried to install proxmox in a new VM with the TV Card installed while installing Proxmox, now the Kernel Module is active.
Maybe someone can declare me the behavior? Why is it not possible to activate the card afterwards?

1 Like

have made further test:
it seems using ROCKSTOR 4.09 based on Opensuse 15.3 does not load the kernel module for this DVB Card, but based on Opensuse 15.2 the kernel module for this DVB-S card is loaded.