Rockstor 4.1.0-0 freezing / fails to install

Hi All,

I have been trying to install Rockstor-Leap15.3-generic.x86_64-4.1.0-0.install.iso onto my HP Microserver N40i.

It would go through the do you want to delete the volume, say yes, then it would upload the file take for ever to do this and then finally start the output below and then freeze. It would not be in the same spot each time. See image below


88171A37-03EA-4378-9422-BA7C0BA6EF39_1_105_c


I did these sort of tests to try and figure out a cause

  • Removed all extra disks
  • Removed the SCSI controller
  • Formatted the primary disk before trying to install
  • Re-seated the memory
  • Installed OpenSUSU Leap this worked
  • When it got stuck I was still able to use the keyboard to reboot the machine
  • When I did reboot it did have a boot loader to select Rockstor 4 as an option this would then freeze at a different point in time

Anything you need me to gather please let me know and I will try my best to get it for you but the system in this state is near impossible to get any data or logs from I feel. There might be a way that you know of that this is possible.

Thanks
Andrew

@agjbond007 Hello there, just working through the backlog of your forum posts.

We are actually working on our next installer. By way of some background, could you let us know which version of openSUSE you tried in the following:

Our current installer is Leap 15.3 based but that is unfortunately now EOL. And we have had ongoing but almost resolved technical difficulties publishing rpms and installers built/based on Lepa 15.4. But given it has a newer kernel it may help compatibility wise. We should also soon have these repositories enabled accordingly. And a number of 15.4 releated/required modifications have already gone into our testing branch which should soon form the basis of our next Stable run. I.e. I’m now doing final testing on 4.5.4-0 which uses a new build systems - one of the issues that has plagued use technically for a number of years now.

So let us know if you are able to install a vanilla server install of openSUSE Leap 15.4 on this hardware as that will be the basis of where we will be, hopefully in the next few days.

Hope that helps.

1 Like

@phillxnet’s answer is the recommendation here. I am curious about one thing, though:
Have you tried the “failsafe” install (GRUB menu option)?
It essentially sets the nomodeset option to the kernel line and I wonder if that would help in this case.
I’m also wondering if there would be some issue with the console setting used by the installer, and those that this HP “allows”… I believe I remember this kind of issue being reported in the past by a user. It seems some microservers like that have some specific console settings that could cause issues sometimes.

1 Like

Hi @Flox & @phillxnet

To @Flox last comment I did try that with the installer with Leap 15.3 and it still would not boot.

To @phillxnet I install Leap 15.4 and it functions really well as an OS.

I am really interested in getting the test version your talking about and installing this onto my server to get back up and running. If this is possible and you have some instructions I am more than happy to give it a go?

Thanks
Andrew

1 Like

@agjbond007 Thanks for feedback.
Re:

Great, yes once we have our new, belated, 15.4 testing repo published as per my other response to you, we are hoping to re-do our installer shortly there after to also be based on 15.4 and include what we hope will be the first stable release candidate rpm 4.5.4-0: to be available in testing channel only first so we can get more field tests before declaring it our new stable release.

But first things first is the 4.5.4-0 rpm to be published to both 15.3 and 15.4 repos. If all goes to plan that is !!!

I’ll update your other thread as mentioned there.

1 Like