Rockstor 500Gb system disk full

Will try, I’ll show the results later. Thx

I think it worked! After I deleted all files inside /mnt2/rockstor_rockstor/root/export, I was able to remove the NFS share.
I noticed that the info of the share was correct (so it must have been pointing all along to the correct disks). So I recreated the NFS Export, went to the urbackup server and it was all there!
Thx for the help @TheRavenKing


Glad you got it sorted, although I am not 100% sure about what you say makes me worried,

It was pointing to rockstor_rockstor which is the system drive!!!

I leave it up to you, but you have to follow all steps to delete the old share and then create a new share to be 100% sure the share goes to the pool and not system disk, see my image and explaination above.

I have this message showing up in the Rockstor terminal, should I worry?

open_ctree failed
failed to read the system array on sda
open_ctree failed


Yip, I was worried.

  • Backup all your files.

ok will do… :worried:

So I followed your instructions but now I’m stuck unable to delete the share.
I get this message


 Share(urbackup) may still be mounted and cannot be deleted. Trying 
again usually succeeds. But if it does not, you can manually unmount it 
with command: /usr/bin/umount /mnt2/urbackup . Error from the OS: ' 
mount: wrong fs type, bad option, bad superblock on /dev/sdb,        
missing codepage or helper program, or other error         In some cases
 useful info is found in syslog - try        dmesg | tail or so. '

When I try the command I get this message:

umount: /mnt2/urbackup: not mounted

I fount out the urbackup folder wasn’t there any longer so I created again and rebooted, but still get the same message

It’s possible that /dev/sdb drive dropped or not scanned. Run btrfs device scan and try deleting the share again.

Thx @suman it worked!

@fictionedge @suman Thanks was busy doing something else urgent. Yeah, it was not all removed, I hope you have removed all shares and mounts and fstab pointers, then perhaps best to do a balance/scrub? when everything is ok, start creating the new share with the correct pool. A big and steep learning curve :wink:

Yes almost done, one last problem here.
This might be the reason of all these problems I had.
In the client machine I created a fstab entry that looks like this /media/urbackup nfs rw,hard,intr,nfsvers=3 0 0

It happens that I need a system user and group called urbackup to have write/read rights to the folder and I’m not getting there.
What do I need to change in the client?

Definitely NOT, you assigned the wrong drive to your share, not sure why you don’t understand this by now?

There are several ways to solve your last ‘issue’.

  • Go to your share, Access control and assign Owner and Group to nfsnobody, set the required permissions.
  • Alternative, create an user with same name and password and UID as on your local system.

That should fix your last issue.

Sorry I’m a bit tired, this is just one of the many problems have been having in the network.

@fictionedge I hope those problems are not so bad then and you can fix them :wink:

Thx @TheRavenKing all is good now. I’ll just spend the next days making a full file backup of all servers