Rockstor 500Gb system disk full

I was having some issues with the raid, one of the disks was showing the error
"mount: wrong fs type, bad option, bad superblock on /dev/sda, missing
codepage or helper program, or other error In some cases useful info is
found in syslog - try dmesg | tail or so."
when I tried to get share it. I’ve run “btrfs device scan” command and then “systemctl restart rockstor” but no luck. So I restarted the system and I was unable to boot. This message appeared in the end of the failed booting sequence
"Dependency failed for /home
Dependency failed for Local File Systems
Dependency failed for Relabel all filesystems, if necessary.
Dependency failed for Mark the need to relabel after reboot."
After a few retries including the rescue option in the boot menu, I choose the previous kernel and it boot it!
I rebooted again now with the correct kernel and all was working.
I found out the problem was the rockstor hard disk was full. It’s a 500Gb hard drive with no shares and for the system only witch is quite strange.
Anyone knows how can I solve this?

@fictionedge Welcome to Rockstor community! Can you provide more info about the full-ness of the drive? Which directories/files are the culprit filling up the space?

This is my df

Filesystem      1K-blocks      Used  Available Use% Mounted on
devtmpfs          1948624         0    1948624   0% /dev
tmpfs             1958492         0    1958492   0% /dev/shm
tmpfs             1958492      8688    1949804   1% /run
tmpfs             1958492         0    1958492   0% /sys/fs/cgroup
/dev/sdd5       483844096 473180092    9270852  99% /
/dev/sdd5       483844096 473180092    9270852  99% /home
/dev/sdd3          487634    126191     331747  28% /boot
/dev/sdd5       483844096 473180092    9270852  99% /mnt2/rockstor_rockstor
/dev/sdc        976762584 875713176  100576824  90% /mnt2/data
/dev/sda       2930266584 436178356 2493466988  15% /mnt2/raidbackup
/dev/sda       2930266584 436178356 2493466988  15% /mnt2/urbackup
/dev/sdc        976762584 875713176  100576824  90% /mnt2/dados

Can you please troubleshoot some more and find out why your / is 99%?

I think I found after alot of digging it’s here /mnt2/rockstor_rockstor/root/export

OMG The problem is with the export of my RAID NFS share, instead of using the disks it’s using the file system! How can I solve this?

Can you detail step by step how you setup the NFS share? please be very specific and elaborate.

I can’t tell exactly the full process since I had a few problems putting the whole thing to work. Here’s what I remember.

First I activated the NFS service, then went and created the pool choosing to use the whole disk.
Then I created the share and moved the slide all the way to the right.
Went into File Share/NFS click Add NFS Export.
Choose the share, add the ip of the target machine in the NFS Client, left the Admin host blank, acces type writable,response type async.
In the target machine add the following line to the fstab /media/urbackup nfs rw,hard,intr,nfsvers=3 0 0

Apparently for some time it was able to write into the correct disk. I’ve listed the real content in the shared folder and it is different from what I see in the remote machine. But now the files inside the export folder are the same I have in the remote machine. It seems for some reason the nfs share isn’t being created properly.

Anyone knows what procedures do I need do to make sure rockstor is creating the export correctly of the raid ?

@fictionedge sure if you explain what you want to archive, how to use it, as much as possible information I am happy to give a helping hand.

Thx @TheRavenKing I’ve decided to copy the files into the correct folder.
I was now trying to delete the NFS share so I could recreate it but no matter what I always get the message “Unable to delete the export(/export/urbackup) because it is in use”. Even after I shutdown the only machine that uses it, disabled the NFS service and rebooting. Do I need to do this manually? If so what do I need to do?

Forgot to mention the purpose, sorry.
I’m using urbackup in a VM with Ubuntu 14.04 Server to create backups of several servers into a Rockstor raid 1 storage.
Its uses hard links so I had to copy all the files with the -a option. It had a few errors, but I’ll clean it up later using a small command line. That’s it!

@fictionedge With NFS shares you have to make sure all shares are killed, so I think your Ubuntu server and/or VM is keeping it up. Shut-down the VM, and see if that does the job, otherwise shut-down the Server and then you should be able to remove it, BUT before you do any of those shut-downs, you must remove on all the machines using the share in the /etc/fstab the line you added, a reboot after that should do the trick!

Sorry for bad English as it is not my mother tongue.

I’ve shutdown the VM witch should be enouth and rebooted rockstor with no results. I’m afraid to change my urbackup installation since I might have problems afterwords.
My English isn’t good either, it’s isn’t my mother tongue too :smile:

@fictionedge Hmm, make sure nothing is using the share then you should be able to delete the share!
Be warned if you remove the share on Rockstor all files in it will be lost, backup. Just one q comes up in my mind. If you virtualized everything on the Ubuntu server then that is your problem I assumed that your Rockstor was not a virtualized but standalone solution.

That’s the strange part, nothing is using it since I created the share specifically to that urbackup IP VM and shutdown the machine
I copied all the files in it with these commands

cd /mnt2/rockstor_rockstor/root/export
yes | cp -a ./urbackup /mnt2/raidbackup


Your making it difficult to support you as you don’t give feedback to the questions :wink:

But I am sure you went wrong when you created the NFS share, but you need to remove that one first!

  • You need to remove that share as you pointed it to the system drive. I have given enough instructions to remove the share, so please read back what I suggested and check.

To create the New share [ for example we create an iso disk share ] do as follow:

  • Shares, create Share, Name: iso, Pool [ The Pool you created, NOT the default rockstor_rockstor that is your system drive ] Then you can use the compression or not options, enter the size, submit.
  • File sharing menu, NFS, Add NFS Export, select your iso from the Shares to export pull-down list. Then enter the IP range select if you want it writeable or not etc… etc… Submit, your done.

That’s it.

1 Like

Sorry for not replying to all. My next question is : after I shutdown the rockstor server service (I’ve done everything else) , how do I remove the NFS share?

  • remove from all your machines the row in the /etc/fstab.
  • remove all files in your current share.
  • shutdown everything except Rockstor.
  • remove the NFS export [BIN icon on end of the nfs export row]
  • remove the NFS share in Rockstor [BIN icon on end of the share row]