Rockstor hanging on delete from nfs client

I’ve got a rockstor setup as NAS with NFS. 16GB memory 12T Raid setup on a PowerEdge R320 Server. I’ve got a proxmox cluster connected using NFS to it.

Lately I’ve been having issues with backing up my lxc containers to an nfs mount on rockstor. Up until two days ago the issues were that some backups were stalled. I saw that I have non completed backup tmp directories on the mount so I tried to delete them. This causes a much bigger problem that rockstor completely hangs. I am no longer able to connect to it remotely, ping it or anything. The only thing left is to restart it. After restart everything works but backups fail on file creation problems and I can’t clean the nfs share without hanging the system.

Happy to hear any thoughts about resolving this.

This sound similar to my issue where copying a 10Gb file or larger freezes up the NFS share. Will come back after the time out. My backups failing as well.

Which version of RockStor are you running. I am running 3.9.1-16.

I hope to upgrade soon to see if my problems disappear.

my version is 3.9.1-0. Tell me if its solved after the upgrade

So I had to unfortunately rebuild my RockStor server. This is the one that cause issues. I installed with base 3.9.1-0 and then immediately updated to the latest version of 3.9.2-48.

Once Installed and mounted the NFS and Samba shares I tried doing my copies. It worked without issues. Couple of things I still need to narrow down:

  1. Only 1 NIC is plugged in currently instead of 2
  2. Completely different DataCenter since I had to move it to rebuild it
    a) Once finally configured I will move it back
  3. Nothing else is connected to it right now.

In short it is working but still need to further test when it is fully implemented. I hope this helps.


@kparr Thanks for the update.

Would be great to know what the actual problems was so do let us know how it all goes.

Glad it’s working thus far though and thanks for helping to support Rockstor’s development via a stable subscription.