Rockstor not coming back from an unexpected reboot

I have been having this issue for some time now and I have worked closely with Suman and together we can not figure out the issue so I’m hoping someone here may be able to help. Whenever I have an unexpected restart Rockstor will not come back up. It has been on all versions, going back to before the paywall was instated. My setup is a Dell 490 workstation with a dual Quad core E5345 Xeon running at 2.33GHz with 8GB of ECC RAM. I have the data drives connected to a LSI RAID card connected via SAS if that makes any difference. I have tried installing to a USB, to a SSD, to something similar to what they sell on the Rockstor store. I continue to have the issue where Rockstor will not come back to life from an unexpected shut down. Can anyone help me please???

Can you let us know what you did with Suman. Doesn’t make much sense to cover the same ground. Also does it throw any errors or just fail to boot.

Finally, you said “unexpected shutdowns” does that mean expected restarts work fine?

Reading your statement I assume you’ve obviously given @suman all available logs, so maybe we can check here after his speech.

Meanwhile, can you provide some logs??


Ill see if I can find the logs of where we talked.

1 Like

I cant find the logs, I guess I was mainly wondering what kind of hardware people were running and if anyone had issues with certain setups. Since I have been having this issue since before the paywall and have tried different medias to install the OS to, that leads me to the CPU, RAM, Motherboard, or Raid card.