Rockstor not connecting to my HBA


I’m testing out Rockstor on my AIO server. The server is running vSphere 6 with a m1015 crossflashed to 9211-8i IT.

When I passthrough the HBA to my Rockstor VM, i’m getting the following error:

[root@ds02 ~]# dmesg|grep mpt2sas
[ 5.346943] mpt2sas version loaded
[ 5.351373] mpt2sas0: 64 BIT PCI BUS DMA ADDRESSING SUPPORTED, total mem (817 5828 kB)
[ 5.423478] mpt2sas0: MSI-X vectors supported: 1, no of cores: 2, max_msix_ve ctors: 8
[ 5.424182] mpt2sas0-msix0: PCI-MSI-X enabled: IRQ 61
[ 5.424185] mpt2sas0: iomem(0x00000000fd4fc000), mapped(0xffffc90000e88000), size(16384)
[ 5.424187] mpt2sas0: ioport(0x0000000000005000), size(256)
[ 5.542787] mpt2sas0: Allocated physical memory: size(7445 kB)
[ 5.542791] mpt2sas0: Current Controller Queue Depth(3307), Max Controller Qu eue Depth(3432)
[ 5.542792] mpt2sas0: Scatter Gather Elements per IO(128)
[ 35.390402] mpt2sas0: _base_event_notification: timeout
[ 35.390448] mpt2sas0: sending message unit reset !!
[ 35.392369] mpt2sas0: message unit reset: SUCCESS
[ 35.595159] mpt2sas0: failure at drivers/scsi/mpt2sas/mpt2sas_scsih.c:8237/_s

The controller is picked up just fine in a debian vm and the napp-it vm I was testing out. I just tried upgrading it to the p20 firmware to see if it was a problem, still not working.

Any thoughts?

I did a fresh install into a new VM and it works now. Not sure if it was a problem with me adding the HBA after the initial install or not.

usually the installers detect any hardware connected during install and package the needed kernel modules into the install, so the module for this m1015 card might not be loaded for your first install, but a generic one which didnt work as expected.

Looks like I spoke too soon. Shut down VM to add an additional nic. Once it came back up, HBA no longer accessible. Same error as before.

I think I got it figured out. Must be some sort of regression in the 4.2.2 kernel.

Reverting back to 4.1.0 has it up and running again.

Im on Kernel 4.2.5, and it is a problem (LSI HBA 9207-8i).

Tried to run areca, but it failed due to too new kernel so off to LSI, which also fails.

Works on 4.1.0 kernel

EDIT: tested on Rockstor 3.8.-8 kernel 4.2.2-1, and it works there as well

EDIT 2: It is a messed up driver. must be fixed ASAP since this is a popular HBA for NAS