Rockstor on Ryzen possible?


I want to install Rockstor 3.9.0 on a system with a Ryzen 1500x. I’m getting various errors like “core perfctr but no constraints; unknown hardware!” and “dracut-timeout”. I know this is too little information to troubleshoot, but as discussed here it seems that Cent OS does not yet have a version for Ryzen. Is that the reason why I cannot install it? If so, when is the expected supporting release?

If that’s not the case I’ll provide a more detailed error report.

Thanks for any help.

@rognod Welcome to the Rockstor community forum.

I would seem so yes. However although our installer is based on a vanilla (old) CentOS kernel; once an initial install is in place and the first reboot is done the system should be on a much newer kernel. If you then activate one of the Update Channels you should then get a much new kernel (currently 4.10.6-1.el7.elrepo.x86_64) once the then available updates are put in and a further reboot is done. There after you might find it will boot just fine on your Ryzen.

So might be worth trying an install on an older system that does work, and then transferring the system drive over to this much newer system. Let us know how it goes. No need to setup any data drives until you have booted the pre-installed system up on the older hardware and established the newer kernel. You can always attached and set them up later.

Hope that helps and do let the forum know how you get on.

1 Like

That’s very helpful, thank you! I’ve never laid my hands on kernel updates or the likes, but I will certainly try and report back if I get something working.

@rognod No worries:

The update mechanism within the user interface of Rockstor, once you have chosen your update channel, should do all of that for you once you click the “Start Update” button on that page. You will just need to reboot afterwards to have it use the newer kernel (once the updates have been installed). We have to use a much newer kernel to get all of the btrfs goodness.


I tried to install Rockstor on a seperate PC from a usb stick to another usb stick. I’ve tried the installation several times, but every time the boot fails with
noveau: 0000:01:00.0 DRM: Pointer to flat panel table invalid.
and the screen goes into power saving mode.
I’m using the latest Rockstor 3.9.0. This PC has an Intel Xeon E3-1231v3 and a Nvidia GTX 970, if that matters.
Is that another “Kernel-too-old” issue?

Thanks again for any help.

@rognod Hello again.

Yes seem that way. The GTX970 (nice card) is second generation maxwell architecture and only supported in newer kernels / noveau drivers so can have serious issues with older kernels such the Rockstor / CentOS 7.x installer uses ie 3.10 or so. However once an update channel is selected and the Rockstor updates are put in and a reboot has moved you over to the much newer kernel of 4.10 then you may well find you are OK. But that’s a very nice gaming graphics card that will be completely wasted in a nas machine.

So since your E3-1231v3 server type chip doesn’t appear to have build in graphics you are going to need to put in something a little less fancy to cater for the old kernel in our installer, at least until you have the newer kernel installed and booting.

Hope that helps.

Thanks. I’ll try a different graphics card.
Just to clear that up, the pc I’m trying to install on is not the NAS machine. Xeon + 970 is my gaming rig, the Ryzen pc will be my NAS machine.

Hey again,

I just wanted to quickly say that I finally got it working. I was able to boot the system on an older graphics card and update it to 4.10. Now it works as expected on the new Ryzen system. I even got Wi-Fi to work :smiley:

Thank you for helping once again!


@rognod Great, well done.

Lots of hardware juggling required on that one but at least you are up and running now.

Thanks for the update, and you are welcome.