Rockstor randomly stops

Ok, so I just got all new components. I have a skylake CPU/mobo, ddr4 ram, and then the rest is pretty standard. Its integrated graphics, 4 HGST hard drives, and until my m.2 ssd comes it, RS is installed on a usb3 thumbdrive. I noticed rockstor will randomly stop responding. I have two NICs, and when I start up, I am able to hit the webgui on both, but after 20-30 minutes, nothing is responding. Even the console is not showing. I am not sure what exactly is happening. If I restart the box, then it starts working, and then later stops. It is not DHCP, nor anything to do with the network. The DHCP leases stay the same, everything is connected to the same switch. I just re-install rockstor, and still the same issue.

I thought maybe it was a hardware issue. So i loaded windows and then used Aida64 for 3 days, no issues…

I also installed the UEFI version of centos 7, and it is stable for over 24 hours.

If someone can give me some assistance manually install rockstor, that would be great. I tried to install by cloning the git repo, then running, but I am erroring out on Setup Tools.