Rockstor service can only be configured from the UI. When configured, it is automatically restarted. To explicitly start/stop/restart, login to the terminal and use systemctl

EDIT: After I wrote this bug report, I tried it again, and it worked :slight_smile:
I have also observed that the 1st time I enabled the Rockstor service, nothing was written to dmesg about the various docker inits.
The 2nd time around, the logs were written to, and my Rockons seem to be working.

Brief description of the problem

Error on trying to stop the Rockon service.
Leap 15.4, V4.5.5-0.

Detailed step by step instructions to reproduce the problem

On Services page enable Rockon, select the root share, wait a few seconds, then press the OFF button.
Note: I selected an already set-up root share, from my previous Rockstor installation (Leap 15.3 V4.5.5-0).

Web-UI screenshot

image

Error Traceback provided on the Web-UI

        Traceback (most recent call last):

File “/opt/rockstor/.venv/lib/python2.7/site-packages/gunicorn/workers/sync.py”, line 68, in run_for_one
self.accept(listener)
File “/opt/rockstor/.venv/lib/python2.7/site-packages/gunicorn/workers/sync.py”, line 27, in accept
client, addr = listener.accept()
File “/usr/lib64/python2.7/socket.py”, line 206, in accept
sock, addr = self._sock.accept()
error: [Errno 11] Resource temporarily unavailable

1 Like